# CVE-2022-24800: Race Condition in October CMS upload process

> Unauthenticated attackers can achieve remote code execution via a race condition in file uploads if plugins expose specific methods.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jul 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-8v7h-cpc2-r8jp

## What is CVE-2022-24800?

CVE-2022-24800 is a high-severity vulnerability in Octobercms October, published on 12 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

October/System is the system module for October CMS, a self-hosted CMS platform based on the Laravel PHP Framework. Prior to versions 1.0.476, 1.1.12, and 2.2.15, when the developer allows the user to specify their own filename in the `fromData` method, an unauthenticated user can perform remote code execution (RCE) by exploiting a race condition in the temporary storage directory. This vulnerability affects plugins that expose the `October\Rain\Database\Attach\File::fromData` as a public interface and does not affect vanilla installations of October CMS since this method is not exposed or used by the system internally or externally. The issue has been patched in Build 476 (v1.0.476), v1.1.12, and v2.2.15. Those who are unable to upgrade may apply with patch to their installation manually as a workaround.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2022-24800?

6 open source packages ship an affected version, including october/system. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `october/system` | Packagist | All versions | 1.0.476 |
| `october/system` | Packagist | All versions | 1.0.476 |
| `october/system` | Packagist | From 1.1.0 | 1.1.12 |
| `october/system` | Packagist | From 1.1.0 | 1.1.12 |
| `october/system` | Packagist | From 2.0.0 | 2.2.15 |
| `october/system` | Packagist | From 2.0.0 | 2.2.15 |

Products: Octobercms October.

## How do I fix CVE-2022-24800?

Upgrade october/system to a fixed version for your release line: 1.0.476, 1.1.12 or 2.2.15.

## Is CVE-2022-24800 being exploited?

There is no known exploitation of CVE-2022-24800 in the wild and no public exploit code.

## Other vulnerabilities in Octobercms October

- [CVE-2021-32648](https://insights.sbomify.com/CVE-2021-32648/): October CMS Improper Authentication (high 8.2, exploited in the wild)
- [CVE-2021-3311](https://insights.sbomify.com/CVE-2021-3311/): October CMS Session ID not invalidated after logout (critical 9.8)
- [CVE-2017-1000194](https://insights.sbomify.com/CVE-2017-1000194/): October CMS File Upload Vulnerability (critical 9.8)
- [CVE-2017-1000196](https://insights.sbomify.com/CVE-2017-1000196/): Code injection in n/a (critical 9.8)
- [CVE-2017-1000197](https://insights.sbomify.com/CVE-2017-1000197/): Path traversal in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24800 and fix it if it is affected.

What it is: CVE-2022-24800 is a high-severity vulnerability in Octobercms October, published on 12 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24800 in the wild and no public exploit code.

Affected packages and fixed versions:
- october/system (Packagist): affected all versions; fixed in 1.0.476
- october/system (Packagist): affected all versions; fixed in 1.0.476
- october/system (Packagist): affected from 1.1.0; fixed in 1.1.12
- october/system (Packagist): affected from 1.1.0; fixed in 1.1.12
- october/system (Packagist): affected from 2.0.0; fixed in 2.2.15
- october/system (Packagist): affected from 2.0.0; fixed in 2.2.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24800/ (Markdown: https://insights.sbomify.com/CVE-2022-24800/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24800
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24800
- OSV: https://osv.dev/vulnerability/CVE-2022-24800

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24800/
Summaries are generated and may contain mistakes; the official description above is the record.
