CVE-2022-24801 HTTP Request Smuggling in twisted.web
Lenient HTTP parsing in Twisted Web server allows request smuggling when proxied, enabling cache poisoning or access control bypass.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-24801?
CVE-2022-24801 is a high-severity vulnerability in Debian Debian Linux, published on 4 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Twisted is an event-based framework for internet applications, supporting Python 3.6+. Prior to version 22.4.0rc1, the Twisted Web HTTP 1.1 server, located in the `twisted.web.http` module, parsed several HTTP request constructs more leniently than permitted by RFC 7230. This non-conformant parsing can lead to desync if requests pass through multiple HTTP parsers, potentially resulting in HTTP request smuggling. Users who may be affected use Twisted Web's HTTP 1.1 server and/or proxy and also pass requests through a different HTTP server and/or proxy. The Twisted Web client is not affected. The HTTP 2.0 server uses a different parser, so it is not affected. The issue has been addressed in Twisted 22.4.0rc1. Two workarounds are available: Ensure any vulnerabilities in upstream proxies have been addressed, such as by upgrading them; or filter malformed requests by other means, such as configuration of an upstream proxy.
Weakness: CWE-444
Which versions are affected by CVE-2022-24801?
3 open source packages ship an affected version, including twisted and Twisted. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
twisted PyPI | All versions | 22.4.0 |
twisted PyPI | All versions | 22.4.0 |
Twisted PyPI | All versions | 22.4.0 |
Linux distribution packages (23)
python-twisted-web Red Hat:enterprise_linux:7::client | All versions | 0:12.1.0-8.el7_9 |
python-twisted-web Red Hat:enterprise_linux:7::computenode | All versions | 0:12.1.0-8.el7_9 |
python-twisted-web Red Hat:enterprise_linux:7::server | All versions | 0:12.1.0-8.el7_9 |
python-twisted-web Red Hat:enterprise_linux:7::workstation | All versions | 0:12.1.0-8.el7_9 |
python-twisted Red Hat:openstack:16.1::el8 | All versions | 0:16.4.1-20.el8ost |
python-twisted-debugsource Red Hat:openstack:16.1::el8 | All versions | 0:16.4.1-20.el8ost |
python3-twisted Red Hat:openstack:16.1::el8 | All versions | 0:16.4.1-20.el8ost |
python3-twisted-debuginfo Red Hat:openstack:16.1::el8 | All versions | 0:16.4.1-20.el8ost |
python-twisted Red Hat:openstack:16.2::el8 | All versions | 0:16.4.1-20.el8ost |
python-twisted-debugsource Red Hat:openstack:16.2::el8 | All versions | 0:16.4.1-20.el8ost |
python3-twisted Red Hat:openstack:16.2::el8 | All versions | 0:16.4.1-20.el8ost |
python3-twisted-debuginfo Red Hat:openstack:16.2::el8 | All versions | 0:16.4.1-20.el8ost |
python-Twisted SUSE:HPE Helion OpenStack 8 | All versions | 15.2.1-9.14.1 |
python-Twisted SUSE:Linux Enterprise Module for Package Hub 15 SP3 | All versions | 19.10.0-150200.3.9.1 |
python-Twisted SUSE:Linux Enterprise Module for Server Applications 15 SP3 | All versions | 19.10.0-150200.3.9.1 |
python-Twisted SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 15.2.1-9.14.1 |
python-Twisted SUSE:Linux Enterprise Real Time 15 SP2 | All versions | 19.10.0-150200.3.9.1 |
python-Twisted SUSE:OpenStack Cloud 8 | All versions | 15.2.1-9.14.1 |
python-Twisted SUSE:OpenStack Cloud 9 | All versions | 15.2.1-9.14.1 |
python-Twisted SUSE:OpenStack Cloud Crowbar 8 | All versions | 15.2.1-9.14.1 |
python-Twisted SUSE:OpenStack Cloud Crowbar 9 | All versions | 15.2.1-9.14.1 |
python-Twisted openSUSE:Leap 15.3 | All versions | 19.10.0-150200.3.9.1 |
python-Twisted openSUSE:Leap 15.4 | All versions | 19.10.0-150200.3.9.1 |
Products include Debian Debian Linux, Fedoraproject Fedora, Oracle Zfs Storage Appliance Kit, Twisted Twisted.
How do I fix CVE-2022-24801?
Upgrade twisted to 22.4.0 or later.
Is CVE-2022-24801 being exploited?
There is no known exploitation of CVE-2022-24801 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2022-24801, DLA-2991-1, GHSA-c2jg-hw38-jrqq, PYSEC-2022-195, RHSA-2022:1645, RHSA-2022:1646 and 5 more.