# CVE-2022-24801: HTTP Request Smuggling in twisted.web

> Lenient HTTP parsing in Twisted Web server allows request smuggling when proxied, enabling cache poisoning or access control bypass.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Apr 2022
- **Updated:** 23 Apr 2025
- **Also known as:** DEBIAN-CVE-2022-24801, DLA-2991-1, GHSA-c2jg-hw38-jrqq, PYSEC-2022-195, RHSA-2022:1645, RHSA-2022:1646, RHSA-2022:4930, SUSE-SU-2022:1477-1, SUSE-SU-2022:1546-1, UBUNTU-CVE-2022-24801, USN-5576-1

## What is CVE-2022-24801?

CVE-2022-24801 is a high-severity vulnerability in Debian Debian Linux, published on 4 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Twisted is an event-based framework for internet applications, supporting Python 3.6+. Prior to version 22.4.0rc1, the Twisted Web HTTP 1.1 server, located in the `twisted.web.http` module, parsed several HTTP request constructs more leniently than permitted by RFC 7230. This non-conformant parsing can lead to desync if requests pass through multiple HTTP parsers, potentially resulting in HTTP request smuggling. Users who may be affected use Twisted Web's HTTP 1.1 server and/or proxy and also pass requests through a different HTTP server and/or proxy. The Twisted Web client is not affected. The HTTP 2.0 server uses a different parser, so it is not affected. The issue has been addressed in Twisted 22.4.0rc1. Two workarounds are available: Ensure any vulnerabilities in upstream proxies have been addressed, such as by upgrading them; or filter malformed requests by other means, such as configuration of an upstream proxy.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2022-24801?

3 open source packages ship an affected version, including twisted and Twisted. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `twisted` | PyPI | All versions | 22.4.0 |
| `twisted` | PyPI | All versions | 22.4.0 |
| `Twisted` | PyPI | All versions | 22.4.0 |
| `python-twisted-web` | Red Hat:enterprise_linux:7::client | All versions | 0:12.1.0-8.el7_9 |
| `python-twisted-web` | Red Hat:enterprise_linux:7::computenode | All versions | 0:12.1.0-8.el7_9 |
| `python-twisted-web` | Red Hat:enterprise_linux:7::server | All versions | 0:12.1.0-8.el7_9 |
| `python-twisted-web` | Red Hat:enterprise_linux:7::workstation | All versions | 0:12.1.0-8.el7_9 |
| `python-twisted` | Red Hat:openstack:16.1::el8 | All versions | 0:16.4.1-20.el8ost |
| `python-twisted-debugsource` | Red Hat:openstack:16.1::el8 | All versions | 0:16.4.1-20.el8ost |
| `python3-twisted` | Red Hat:openstack:16.1::el8 | All versions | 0:16.4.1-20.el8ost |
| `python3-twisted-debuginfo` | Red Hat:openstack:16.1::el8 | All versions | 0:16.4.1-20.el8ost |
| `python-twisted` | Red Hat:openstack:16.2::el8 | All versions | 0:16.4.1-20.el8ost |
| `python-twisted-debugsource` | Red Hat:openstack:16.2::el8 | All versions | 0:16.4.1-20.el8ost |
| `python3-twisted` | Red Hat:openstack:16.2::el8 | All versions | 0:16.4.1-20.el8ost |
| `python3-twisted-debuginfo` | Red Hat:openstack:16.2::el8 | All versions | 0:16.4.1-20.el8ost |
| `python-Twisted` | SUSE:HPE Helion OpenStack 8 | All versions | 15.2.1-9.14.1 |
| `python-Twisted` | SUSE:Linux Enterprise Module for Package Hub 15 SP3 | All versions | 19.10.0-150200.3.9.1 |
| `python-Twisted` | SUSE:Linux Enterprise Module for Server Applications 15 SP3 | All versions | 19.10.0-150200.3.9.1 |
| `python-Twisted` | SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 15.2.1-9.14.1 |
| `python-Twisted` | SUSE:Linux Enterprise Real Time 15 SP2 | All versions | 19.10.0-150200.3.9.1 |
| `python-Twisted` | SUSE:OpenStack Cloud 8 | All versions | 15.2.1-9.14.1 |
| `python-Twisted` | SUSE:OpenStack Cloud 9 | All versions | 15.2.1-9.14.1 |
| `python-Twisted` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 15.2.1-9.14.1 |
| `python-Twisted` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 15.2.1-9.14.1 |
| `python-Twisted` | openSUSE:Leap 15.3 | All versions | 19.10.0-150200.3.9.1 |
| `python-Twisted` | openSUSE:Leap 15.4 | All versions | 19.10.0-150200.3.9.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Oracle Zfs Storage Appliance Kit, Twisted Twisted.

## How do I fix CVE-2022-24801?

Upgrade twisted to 22.4.0 or later.

## Is CVE-2022-24801 being exploited?

There is no known exploitation of CVE-2022-24801 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24801 and fix it if it is affected.

What it is: CVE-2022-24801 is a high-severity vulnerability in Debian Debian Linux, published on 4 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24801 in the wild and no public exploit code.

Affected packages and fixed versions:
- twisted (PyPI): affected all versions; fixed in 22.4.0
- twisted (PyPI): affected all versions; fixed in 22.4.0
- Twisted (PyPI): affected all versions; fixed in 22.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24801/ (Markdown: https://insights.sbomify.com/CVE-2022-24801/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24801
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24801
- OSV: https://osv.dev/vulnerability/CVE-2022-24801

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24801/
Summaries are generated and may contain mistakes; the official description above is the record.
