# CVE-2022-24802: Prototype Pollution in deepmerge-ts

> Prototype pollution in deepmerge-ts allows attackers to modify object prototypes, potentially leading to code execution or privilege escalation.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-r9w3-g83q-m6hq

## What is CVE-2022-24802?

CVE-2022-24802 is a high-severity vulnerability in RebeccaStevens deepmerge-ts, published on 31 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

deepmerge-ts is a typescript library providing functionality to deep merging of javascript objects. deepmerge-ts is vulnerable to Prototype Pollution via file deepmerge.ts, function defaultMergeRecords(). This issue has been patched in version 4.0.2. There are no known workarounds for this issue.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes), CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes)

## Which versions are affected by CVE-2022-24802?

2 open source packages ship an affected version, including deepmerge-ts. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deepmerge-ts` | npm | All versions | 4.0.2 |
| `deepmerge-ts` | npm | All versions | 4.0.2 |

Products: Deepmerge-Ts Project Deepmerge-Ts.

## How do I fix CVE-2022-24802?

Upgrade deepmerge-ts to 4.0.2 or later.

## Is CVE-2022-24802 being exploited?

There is no known exploitation of CVE-2022-24802 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24802 and fix it if it is affected.

What it is: CVE-2022-24802 is a high-severity vulnerability in RebeccaStevens deepmerge-ts, published on 31 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24802 in the wild and no public exploit code.

Affected packages and fixed versions:
- deepmerge-ts (npm): affected all versions; fixed in 4.0.2
- deepmerge-ts (npm): affected all versions; fixed in 4.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24802/ (Markdown: https://insights.sbomify.com/CVE-2022-24802/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24802
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24802
- OSV: https://osv.dev/vulnerability/CVE-2022-24802

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24802/
Summaries are generated and may contain mistakes; the official description above is the record.
