{"answers":{"affected":"2 open source packages ship an affected version, including asciidoctor-include-ext. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24803 exists.","fix":"Upgrade asciidoctor-include-ext to 0.4.0 or later.","what":"CVE-2022-24803 is a critical command injection vulnerability in jirutka asciidoctor-include-ext, published on 31 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24803 and fix it if it is affected.\n\nWhat it is: CVE-2022-24803 is a critical command injection vulnerability in jirutka asciidoctor-include-ext, published on 31 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24803 exists.\n\nAffected packages and fixed versions:\n- asciidoctor-include-ext (RubyGems): affected all versions; fixed in 0.4.0\n- asciidoctor-include-ext (RubyGems): affected all versions; fixed in 0.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24803/ (Markdown: https://insights.sbomify.com/CVE-2022-24803/index.md)","id":"CVE-2022-24803","markdown":"https://insights.sbomify.com/CVE-2022-24803/index.md","name":"CVE-2022-24803","record":{"aliases":["DEBIAN-CVE-2022-24803","GHSA-v222-6mr4-qj29","UBUNTU-CVE-2022-24803"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby AsciiDoc extension","requires_auth":"none","summary":"Attackers can execute arbitrary system commands via user-supplied AsciiDoc markup in the asciidoctor-include-ext library.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"asciidoctor-include-ext","vendor":"asciidoctor-include-ext_project"}],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Asciidoctor-include-ext is Asciidoctor’s standard include processor reimplemented as an extension. Versions prior to 0.4.0, when used to render user-supplied input in AsciiDoc markup, may allow an attacker to execute arbitrary system commands on the host operating system. This attack is possible even when `allow-uri-read` is disabled! The problem has been patched in the referenced commits.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Command Injection vulnerability in asciidoctor-include-ext","id":"CVE-2022-24803","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Private group name exposure in discourse","id":"CVE-2022-24804"},"packages":[{"ecosystem":"RubyGems","fixed":["0.4.0"],"introduced":["0"],"last_affected":[],"package":"asciidoctor-include-ext","purl":null,"source":"GHSA-v222-6mr4-qj29"},{"ecosystem":"RubyGems","fixed":["0.4.0"],"introduced":["0"],"last_affected":[],"package":"asciidoctor-include-ext","purl":"pkg:gem/asciidoctor-include-ext","source":"GHSA-v222-6mr4-qj29"}],"prev":{"headline":"Prototype Pollution in deepmerge-ts","id":"CVE-2022-24802"},"products":["asciidoctor-include-ext"],"published":"2022-03-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["jirutka"]},"summary":"Attackers can execute arbitrary system commands via user-supplied AsciiDoc markup in the asciidoctor-include-ext library.","url":"https://insights.sbomify.com/CVE-2022-24803/"}