# CVE-2022-24803: Command Injection vulnerability in asciidoctor-include-ext

> Attackers can execute arbitrary system commands via user-supplied AsciiDoc markup in the asciidoctor-include-ext library.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2022
- **Updated:** 22 Apr 2025
- **Also known as:** DEBIAN-CVE-2022-24803, GHSA-v222-6mr4-qj29, UBUNTU-CVE-2022-24803

## What is CVE-2022-24803?

CVE-2022-24803 is a critical command injection vulnerability in jirutka asciidoctor-include-ext, published on 31 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Asciidoctor-include-ext is Asciidoctor’s standard include processor reimplemented as an extension. Versions prior to 0.4.0, when used to render user-supplied input in AsciiDoc markup, may allow an attacker to execute arbitrary system commands on the host operating system. This attack is possible even when `allow-uri-read` is disabled! The problem has been patched in the referenced commits.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2022-24803?

2 open source packages ship an affected version, including asciidoctor-include-ext. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `asciidoctor-include-ext` | RubyGems | All versions | 0.4.0 |
| `asciidoctor-include-ext` | RubyGems | All versions | 0.4.0 |

Products: Asciidoctor-Include-Ext Project Asciidoctor-Include-Ext.

## How do I fix CVE-2022-24803?

Upgrade asciidoctor-include-ext to 0.4.0 or later.

## Is CVE-2022-24803 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24803 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24803 and fix it if it is affected.

What it is: CVE-2022-24803 is a critical command injection vulnerability in jirutka asciidoctor-include-ext, published on 31 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24803 exists.

Affected packages and fixed versions:
- asciidoctor-include-ext (RubyGems): affected all versions; fixed in 0.4.0
- asciidoctor-include-ext (RubyGems): affected all versions; fixed in 0.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24803/ (Markdown: https://insights.sbomify.com/CVE-2022-24803/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24803
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24803
- OSV: https://osv.dev/vulnerability/CVE-2022-24803

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24803/
Summaries are generated and may contain mistakes; the official description above is the record.
