CVE-2022-24811 Cross-site Scripting in Combodo iTop

Medium 5.4 Published Updated

Attackers can execute arbitrary scripts via HTML attachments in Combodo iTop, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2022-24811?

CVE-2022-24811 is a medium-severity cross-site scripting vulnerability in Combodo Itop, published on 5 Apr 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Combodi iTop is a web based IT Service Management tool. Prior to versions 2.7.6 and 3.0.0, cross-site scripting is possible for scripts outside of script tags when displaying HTML attachments. This issue is fixed in versions 2.7.6 and 3.0.0. There are currently no known workarounds.

Weakness: CWE-79

Which versions are affected by CVE-2022-24811?

It affects 1 product.

Products include Combodo Itop.

How do I fix CVE-2022-24811?

No fix has been published for CVE-2022-24811 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-24811 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24811 exists.

All Combodo Itop vulnerabilities

Sources

Also known as GHSA-67x5-mqg4-rvgc.

Is CVE-2022-24811 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free