# CVE-2022-24811: Cross-site Scripting in Combodo iTop

> Attackers can execute arbitrary scripts via HTML attachments in Combodo iTop, potentially compromising user sessions.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 5 Apr 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-67x5-mqg4-rvgc

## What is CVE-2022-24811?

CVE-2022-24811 is a medium-severity cross-site scripting vulnerability in Combodo Itop, published on 5 Apr 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Combodi iTop is a web based IT Service Management tool. Prior to versions 2.7.6 and 3.0.0, cross-site scripting is possible for scripts outside of script tags when displaying HTML attachments. This issue is fixed in versions 2.7.6 and 3.0.0. There are currently no known workarounds.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-24811?

It affects 1 product.


Products: Combodo Itop.

## How do I fix CVE-2022-24811?

No fix has been published for CVE-2022-24811 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-24811 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24811 exists.

## Other vulnerabilities in Combodo Itop

- [CVE-2023-48710](https://insights.sbomify.com/CVE-2023-48710/): iTop limit pages/exec.php script to PHP files (critical 9.8)
- [CVE-2022-39214](https://insights.sbomify.com/CVE-2022-39214/): Authenticated users of Combodo iTop can take over any account (critical 9.6)
- [CVE-2021-41161](https://insights.sbomify.com/CVE-2021-41161/): XSS in csvimport in 3.0.0-beta versions (critical 9.3)
- [CVE-2021-41162](https://insights.sbomify.com/CVE-2021-41162/): Cross-site Scripting in Combodo iTop (critical 9.3)
- [CVE-2025-47773](https://insights.sbomify.com/CVE-2025-47773/): Combodo iTop has XSS vulnerability in /pages/ajax.render.php (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24811 and fix it if it is affected.

What it is: CVE-2022-24811 is a medium-severity cross-site scripting vulnerability in Combodo Itop, published on 5 Apr 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24811 exists.

Affected product: Combodo Itop. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24811/ (Markdown: https://insights.sbomify.com/CVE-2022-24811/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24811
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24811
- OSV: https://osv.dev/vulnerability/CVE-2022-24811

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24811/
Summaries are generated and may contain mistakes; the official description above is the record.
