# CVE-2022-24812: FGAC API Key privilege escalation in Grafana

> Attackers can escalate privileges by exploiting a caching flaw in Grafana Enterprise's fine-grained access control when multiple API keys are used.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Apr 2022
- **Updated:** 28 Jan 2026
- **Also known as:** BIT-grafana-2022-24812, GHSA-82gq-xfg3-5j7v

## What is CVE-2022-24812?

CVE-2022-24812 is a high-severity vulnerability in Grafana Grafana, published on 12 Apr 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Grafana is an open-source platform for monitoring and observability. When fine-grained access control is enabled and a client uses Grafana API Key to make requests, the permissions for that API Key are cached for 30 seconds for the given organization. Because of the way the cache ID is constructed, the consequent requests with any API Key evaluate to the same permissions as the previous requests. This can lead to an escalation of privileges, when for example a first request is made with Admin permissions, and the second request with different API Key is made with Viewer permissions, the second request will get the cached permissions from the previous Admin, essentially accessing higher privilege than it should. The vulnerability is only impacting Grafana Enterprise when the fine-grained access control beta feature is enabled and there are more than one API Keys in one organization with different roles assigned. All installations after Grafana Enterprise v8.1.0-beta1 should be upgraded as soon as possible. As an alternative, disable fine-grained access control will mitigate the vulnerability.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2022-24812?

1 open source package ship an affected version, including grafana. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `grafana` | Bitnami | From 8.1.0 | 8.4.6 |

Products: Grafana Grafana.

## How do I fix CVE-2022-24812?

Upgrade grafana to 8.4.6 or later.

## Is CVE-2022-24812 being exploited?

There is no known exploitation of CVE-2022-24812 in the wild and no public exploit code.

## Other vulnerabilities in Grafana Grafana

- [CVE-2021-43798](https://insights.sbomify.com/CVE-2021-43798/): Grafana Path Traversal (high 7.5, exploited in the wild)
- [CVE-2025-41115](https://insights.sbomify.com/CVE-2025-41115/): Incorrect privilege assignment (critical 10.0)
- [CVE-2022-39328](https://insights.sbomify.com/CVE-2022-39328/): Grafana vulnerable to race condition allowing privilege escalation (critical 9.8)
- [CVE-2022-28660](https://insights.sbomify.com/CVE-2022-28660/): Auth bypass in n/a (critical 9.8)
- [CVE-2022-26148](https://insights.sbomify.com/CVE-2022-26148/): Information disclosure in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24812 and fix it if it is affected.

What it is: CVE-2022-24812 is a high-severity vulnerability in Grafana Grafana, published on 12 Apr 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24812 in the wild and no public exploit code.

Affected packages and fixed versions:
- grafana (Bitnami): affected from 8.1.0; fixed in 8.4.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24812/ (Markdown: https://insights.sbomify.com/CVE-2022-24812/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24812
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24812
- OSV: https://osv.dev/vulnerability/CVE-2022-24812

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24812/
Summaries are generated and may contain mistakes; the official description above is the record.
