{"answers":{"affected":"4 open source packages ship an affected version, including it.geosolutions.jaiext.jiffle:jt-jiffle and it.geosolutions.jaiext.jiffle:jt-jiffle-language. It affects 1 product.","exploited":"Yes. Attackers have exploited CVE-2022-24816 in the wild since at least 26 Jun 2024.","fix":"Upgrade it.geosolutions.jaiext.jiffle:jt-jiffle to 1.1.22 or later. US federal agencies must fix it by 17 Jul 2024.","what":"CVE-2022-24816 is a critical code injection vulnerability in geosolutions-it jai-ext, published on 13 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24816 and fix it if it is affected.\n\nWhat it is: CVE-2022-24816 is a critical code injection vulnerability in geosolutions-it jai-ext, published on 13 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: Yes. Attackers have exploited CVE-2022-24816 in the wild since at least 26 Jun 2024.\n\nAffected packages and fixed versions:\n- it.geosolutions.jaiext.jiffle:jt-jiffle (Maven): affected all versions; fixed in 1.1.22\n- it.geosolutions.jaiext.jiffle:jt-jiffle (Maven): affected all versions; fixed in 1.1.22\n- it.geosolutions.jaiext.jiffle:jt-jiffle-language (Maven): affected all versions; fixed in 1.1.22\n- it.geosolutions.jaiext.jiffle:jt-jiffle-language (Maven): affected all versions; fixed in 1.1.22\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24816/ (Markdown: https://insights.sbomify.com/CVE-2022-24816/index.md)","id":"CVE-2022-24816","markdown":"https://insights.sbomify.com/CVE-2022-24816/index.md","name":"CVE-2022-24816","record":{"aliases":["GHSA-v92f-jx6p-73rx"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Java imaging library","requires_auth":"none","summary":"Attackers can execute arbitrary code via Jiffle scripts in applications using jai-ext, requiring network access to script submission.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"jai-ext","vendor":"geosolutionsgroup"}],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"JAI-EXT is an open-source project which aims to extend the Java Advanced Imaging (JAI) API. Programs allowing Jiffle script to be provided via network request can lead to a Remote Code Execution as the Jiffle script is compiled into Java code via Janino, and executed. In particular, this affects the downstream GeoServer project. Version 1.2.22 will contain a patch that disables the ability to inject malicious code into the resulting script. Users unable to upgrade may negate the ability to compile Jiffle scripts from the final application, by removing janino-x.y.z.jar from the classpath.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":"2025-01-17","github_poc":1,"max_poc_stars":1,"metasploit":0,"nuclei":1,"refs":[{"date":"2025-01-17T12:50:48Z","kind":"github_poc","ref":"https://github.com/c1ph3rbyt3/CVE-2022-24816","stars":1,"title":null},{"date":null,"kind":"nuclei","ref":"http/cves/2022/CVE-2022-24816.yaml","stars":null,"title":"GeoServer \u003c1.2.2 - Remote Code Execution"}],"tier":"exploited"},"has_fix":true,"headline":"OSGeo GeoServer JAI-EXT Code Injection","id":"CVE-2022-24816","indexable":true,"kev":{"dateAdded":"2024-06-26","dueDate":"2024-07-17","knownRansomwareCampaignUse":"Unknown","product":"JAI-EXT","requiredAction":"Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.","vendorProject":"OSGeo","vulnerabilityName":"OSGeo GeoServer JAI-EXT Code Injection Vulnerability"},"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2022"},"n_packages":4,"n_references":2,"next":{"headline":"Improper kubeconfig validation allows arbitrary code execution","id":"CVE-2022-24817"},"packages":[{"ecosystem":"Maven","fixed":["1.1.22"],"introduced":["0"],"last_affected":[],"package":"it.geosolutions.jaiext.jiffle:jt-jiffle","purl":null,"source":"GHSA-v92f-jx6p-73rx"},{"ecosystem":"Maven","fixed":["1.1.22"],"introduced":["0"],"last_affected":[],"package":"it.geosolutions.jaiext.jiffle:jt-jiffle","purl":"pkg:maven/it.geosolutions.jaiext.jiffle/jt-jiffle","source":"GHSA-v92f-jx6p-73rx"},{"ecosystem":"Maven","fixed":["1.1.22"],"introduced":["0"],"last_affected":[],"package":"it.geosolutions.jaiext.jiffle:jt-jiffle-language","purl":null,"source":"GHSA-v92f-jx6p-73rx"},{"ecosystem":"Maven","fixed":["1.1.22"],"introduced":["0"],"last_affected":[],"package":"it.geosolutions.jaiext.jiffle:jt-jiffle-language","purl":"pkg:maven/it.geosolutions.jaiext.jiffle/jt-jiffle-language","source":"GHSA-v92f-jx6p-73rx"}],"prev":{"headline":"SQL Injection when creating an application with Reactive SQL backend","id":"CVE-2022-24815"},"products":["jai-ext"],"published":"2022-04-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"open","licence":"CC0 1.0","name":"CISA KEV"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"active","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-10-21","vendors":["geosolutions-it"]},"summary":"Attackers can execute arbitrary code via Jiffle scripts in applications using jai-ext, requiring network access to script submission.","url":"https://insights.sbomify.com/CVE-2022-24816/"}