# CVE-2022-24817: Improper kubeconfig validation allows arbitrary code execution

> Attackers can execute arbitrary code and escalate privileges by submitting malicious kubeconfig files to Flux2 controllers.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 May 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-flux-2022-24817, BIT-kustomize-2022-24817, GHSA-vvmq-fwmg-2gjc

## What is CVE-2022-24817?

CVE-2022-24817 is a critical code injection vulnerability in fluxcd flux2, published on 6 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flux2 is an open and extensible continuous delivery solution for Kubernetes. Flux2 versions between 0.1.0 and 0.29.0, helm-controller 0.1.0 to v0.19.0, and kustomize-controller 0.1.0 to v0.23.0 are vulnerable to Code Injection via malicious Kubeconfig. In multi-tenancy deployments this can also lead to privilege escalation if the controller's service account has elevated permissions. Workarounds include disabling functionality via Validating Admission webhooks by restricting users from setting the `spec.kubeConfig` field in Flux `Kustomization` and `HelmRelease` objects. Additional mitigations include applying restrictive AppArmor and SELinux profiles on the controller’s pod to limit what binaries can be executed. This vulnerability is fixed in kustomize-controller v0.23.0 and helm-controller v0.19.0, both included in flux2 v0.29.0

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2022-24817?

8 open source packages ship an affected version, including github.com/fluxcd/flux2, flux and kustomize. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/fluxcd/flux2` | Go | From 0.1.0 | 0.29.0 |
| `github.com/fluxcd/flux2` | Go | From 0.1.0 | 0.29.0 |
| `flux` | Bitnami | From 0.1.0 | 0.29.0 |
| `kustomize` | Bitnami | From 0.1.0 | 0.23.0 |
| `github.com/fluxcd/helm-controller` | Go | From 0.2.0 | 0.19.0 |
| `github.com/fluxcd/helm-controller` | Go | From 0.2.0 | 0.19.0 |
| `github.com/fluxcd/kustomize-controller` | Go | From 0.1.0 | 0.23.0 |
| `github.com/fluxcd/kustomize-controller` | Go | From 0.1.0 | 0.23.0 |

Products: Fluxcd Flux2, Fluxcd Helm-Controller, Fluxcd Kustomize-Controller.

## How do I fix CVE-2022-24817?

Upgrade github.com/fluxcd/flux2 to 0.29.0 or later.

## Is CVE-2022-24817 being exploited?

There is no known exploitation of CVE-2022-24817 in the wild and no public exploit code.

## Other vulnerabilities in fluxcd flux2

- [CVE-2022-24877](https://insights.sbomify.com/CVE-2022-24877/): Improper path handling in kustomization files allows path traversal (critical 9.9)
- [CVE-2022-36049](https://insights.sbomify.com/CVE-2022-36049/): Flux2 Helm Controller denial of service (high 7.7)
- [CVE-2022-36035](https://insights.sbomify.com/CVE-2022-36035/): Flux CLI Workload Injection (high 7.7)
- [CVE-2022-24878](https://insights.sbomify.com/CVE-2022-24878/): Improper path handling in Kustomization files allows for denial of service (high 7.7)
- [CVE-2022-39272](https://insights.sbomify.com/CVE-2022-39272/): Flux2 vulnerable to Denial of Service due to Improper use of metav1.Duration (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24817 and fix it if it is affected.

What it is: CVE-2022-24817 is a critical code injection vulnerability in fluxcd flux2, published on 6 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24817 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/fluxcd/flux2 (Go): affected from 0.1.0; fixed in 0.29.0
- github.com/fluxcd/flux2 (Go): affected from 0.1.0; fixed in 0.29.0
- flux (Bitnami): affected from 0.1.0; fixed in 0.29.0
- kustomize (Bitnami): affected from 0.1.0; fixed in 0.23.0
- github.com/fluxcd/helm-controller (Go): affected from 0.2.0; fixed in 0.19.0
- github.com/fluxcd/helm-controller (Go): affected from 0.2.0; fixed in 0.19.0
- github.com/fluxcd/kustomize-controller (Go): affected from 0.1.0; fixed in 0.23.0
- github.com/fluxcd/kustomize-controller (Go): affected from 0.1.0; fixed in 0.23.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24817/ (Markdown: https://insights.sbomify.com/CVE-2022-24817/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24817
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24817
- OSV: https://osv.dev/vulnerability/CVE-2022-24817

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24817/
Summaries are generated and may contain mistakes; the official description above is the record.
