# CVE-2022-24820: Unauthenticated user can list hidden document from multiple velocity templates

> Unauthenticated users can list hidden documents by rendering specific velocity templates, bypassing view restrictions.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Apr 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-qpp2-2mcp-2wm5

## What is CVE-2022-24820?

CVE-2022-24820 is a medium-severity missing authorization vulnerability in Xwiki Xwiki, published on 8 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. A guest user without the right to view pages of the wiki can still list documents by rendering some velocity documents. The problem has been patched in XWiki versions 12.10.11, 13.4.4, and 13.9-rc-1. There is no known workaround for this problem.

Weakness: CWE-306 (Missing Authentication for Critical Functionality), CWE-359 (Exposure of Private Personal Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-24820?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-web` | Maven | All versions | 12.10.11 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | All versions | 12.10.11 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | From 13.0.0 | 13.4.4 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | From 13.0.0 | 13.4.4 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | From 13.5.0 | 13.9 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | From 13.5.0 | 13.9 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-24820?

Upgrade org.xwiki.platform:xwiki-platform-web to a fixed version for your release line: 12.10.11, 13.4.4 or 13.9.

## Is CVE-2022-24820 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24820 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24820 and fix it if it is affected.

What it is: CVE-2022-24820 is a medium-severity missing authorization vulnerability in Xwiki Xwiki, published on 8 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24820 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-web (Maven): affected all versions; fixed in 12.10.11
- org.xwiki.platform:xwiki-platform-web (Maven): affected all versions; fixed in 12.10.11
- org.xwiki.platform:xwiki-platform-web (Maven): affected from 13.0.0; fixed in 13.4.4
- org.xwiki.platform:xwiki-platform-web (Maven): affected from 13.0.0; fixed in 13.4.4
- org.xwiki.platform:xwiki-platform-web (Maven): affected from 13.5.0; fixed in 13.9
- org.xwiki.platform:xwiki-platform-web (Maven): affected from 13.5.0; fixed in 13.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24820/ (Markdown: https://insights.sbomify.com/CVE-2022-24820/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24820
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24820
- OSV: https://osv.dev/vulnerability/CVE-2022-24820

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24820/
Summaries are generated and may contain mistakes; the official description above is the record.
