# CVE-2022-24821: Incorrect Use of Privileged APIs in org.xwiki.platform.skin.skinx

> Users with edit rights can create global scripts, bypassing programming rights restrictions to execute code across the wiki.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Apr 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-ghcq-472w-vf4h

## What is CVE-2022-24821?

CVE-2022-24821 is a medium-severity vulnerability in Xwiki Xwiki, published on 8 Apr 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Simple users can create global SSX/JSX without specific rights: in theory only users with Programming Rights should be allowed to create SSX or JSX that are executed everywhere on a wiki. But a bug allow anyone with edit rights to actually create those. This issue has been patched in XWiki 13.10-rc-1, 12.10.11 and 13.4.6. There's no easy workaround for this issue, administrators should upgrade their wiki.

Weakness: CWE-648 (Incorrect Use of Privileged APIs)

## Which versions are affected by CVE-2022-24821?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-skin-skinx. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-skin-skinx` | Maven | All versions | 12.10.11 |
| `org.xwiki.platform:xwiki-platform-skin-skinx` | Maven | All versions | 12.10.11 |
| `org.xwiki.platform:xwiki-platform-skin-skinx` | Maven | From 13.0.0 | 13.4.6 |
| `org.xwiki.platform:xwiki-platform-skin-skinx` | Maven | From 13.0.0 | 13.4.6 |
| `org.xwiki.platform:xwiki-platform-skin-skinx` | Maven | From 13.5.0 | 13.10 |
| `org.xwiki.platform:xwiki-platform-skin-skinx` | Maven | From 13.5.0 | 13.10 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-24821?

Upgrade org.xwiki.platform:xwiki-platform-skin-skinx to a fixed version for your release line: 12.10.11, 13.4.6 or 13.10.

## Is CVE-2022-24821 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24821 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24821 and fix it if it is affected.

What it is: CVE-2022-24821 is a medium-severity vulnerability in Xwiki Xwiki, published on 8 Apr 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24821 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-skin-skinx (Maven): affected all versions; fixed in 12.10.11
- org.xwiki.platform:xwiki-platform-skin-skinx (Maven): affected all versions; fixed in 12.10.11
- org.xwiki.platform:xwiki-platform-skin-skinx (Maven): affected from 13.0.0; fixed in 13.4.6
- org.xwiki.platform:xwiki-platform-skin-skinx (Maven): affected from 13.0.0; fixed in 13.4.6
- org.xwiki.platform:xwiki-platform-skin-skinx (Maven): affected from 13.5.0; fixed in 13.10
- org.xwiki.platform:xwiki-platform-skin-skinx (Maven): affected from 13.5.0; fixed in 13.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24821/ (Markdown: https://insights.sbomify.com/CVE-2022-24821/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24821
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24821
- OSV: https://osv.dev/vulnerability/CVE-2022-24821

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24821/
Summaries are generated and may contain mistakes; the official description above is the record.
