{"answers":{"affected":"4 open source packages ship an affected version, including @podium/proxy and @podium/layout. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-24822 in the wild and no public exploit code.","fix":"Upgrade @podium/proxy to 4.2.74 or later.","what":"CVE-2022-24822 is a high-severity denial of service vulnerability in podium-lib proxy, published on 6 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24822 and fix it if it is affected.\n\nWhat it is: CVE-2022-24822 is a high-severity denial of service vulnerability in podium-lib proxy, published on 6 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-24822 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @podium/proxy (npm): affected all versions; fixed in 4.2.74\n- @podium/proxy (npm): affected all versions; fixed in 4.2.74\n- @podium/layout (npm): affected all versions; fixed in 4.6.110\n- @podium/layout (npm): affected all versions; fixed in 4.6.110\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24822/ (Markdown: https://insights.sbomify.com/CVE-2022-24822/index.md)","id":"CVE-2022-24822","markdown":"https://insights.sbomify.com/CVE-2022-24822/index.md","name":"CVE-2022-24822","record":{"aliases":["GHSA-3hjg-vc7r-rcrw"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Podium micro frontend library","requires_auth":"none","summary":"An attacker can crash the server by sending a malicious Trailer header to proxy endpoints in Podium layout libraries.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"podium_layout","vendor":"finn"},{"product":"podium_proxy","vendor":"finn"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-248","name":"Uncaught Exception"}],"description":"Podium is a library for building micro frontends. @podium/layout is a module for building a Podium layout server, and @podium/proxy is a module for proxying HTTP requests from a layout server to a podlet server. In @podium/layout prior to version 4.6.110 and @podium/proxy prior to version 4.2.74, an attacker using the `Trailer` header as part of the request against proxy endpoints has the ability to take down the server. All Podium layouts that include podlets with proxy endpoints are affected. `@podium/layout`, which is the main way developers/users are vulnerable to this exploit, has been patched in version `4.6.110`. All earlier versions are vulnerable.`@podium/proxy`, which is the source of the vulnerability and is used by `@podium/layout` has been patched in version `4.2.74`. All earlier versions are vulnerable. It is not easily possible to work around this issue without upgrading.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service in @podium/layout and @podium/proxy","id":"CVE-2022-24822","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":4,"n_references":5,"next":{"headline":"Local Information Disclosure Vulnerability in io.netty:netty-codec-http","id":"CVE-2022-24823"},"packages":[{"ecosystem":"npm","fixed":["4.6.110"],"introduced":["0"],"last_affected":[],"package":"@podium/layout","purl":null,"source":"GHSA-3hjg-vc7r-rcrw"},{"ecosystem":"npm","fixed":["4.6.110"],"introduced":["0"],"last_affected":[],"package":"@podium/layout","purl":"pkg:npm/%40podium/layout","source":"GHSA-3hjg-vc7r-rcrw"},{"ecosystem":"npm","fixed":["4.2.74"],"introduced":["0"],"last_affected":[],"package":"@podium/proxy","purl":null,"source":"GHSA-3hjg-vc7r-rcrw"},{"ecosystem":"npm","fixed":["4.2.74"],"introduced":["0"],"last_affected":[],"package":"@podium/proxy","purl":"pkg:npm/%40podium/proxy","source":"GHSA-3hjg-vc7r-rcrw"}],"prev":{"headline":"Incorrect Use of Privileged APIs in org.xwiki.platform.skin.skinx","id":"CVE-2022-24821"},"products":["proxy"],"published":"2022-04-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["podium-lib"]},"summary":"An attacker can crash the server by sending a malicious Trailer header to proxy endpoints in Podium layout libraries.","url":"https://insights.sbomify.com/CVE-2022-24822/"}