# CVE-2022-24822: Denial of Service in @podium/layout and @podium/proxy

> An attacker can crash the server by sending a malicious Trailer header to proxy endpoints in Podium layout libraries.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Apr 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-3hjg-vc7r-rcrw

## What is CVE-2022-24822?

CVE-2022-24822 is a high-severity denial of service vulnerability in podium-lib proxy, published on 6 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Podium is a library for building micro frontends. @podium/layout is a module for building a Podium layout server, and @podium/proxy is a module for proxying HTTP requests from a layout server to a podlet server. In @podium/layout prior to version 4.6.110 and @podium/proxy prior to version 4.2.74, an attacker using the `Trailer` header as part of the request against proxy endpoints has the ability to take down the server. All Podium layouts that include podlets with proxy endpoints are affected. `@podium/layout`, which is the main way developers/users are vulnerable to this exploit, has been patched in version `4.6.110`. All earlier versions are vulnerable.`@podium/proxy`, which is the source of the vulnerability and is used by `@podium/layout` has been patched in version `4.2.74`. All earlier versions are vulnerable. It is not easily possible to work around this issue without upgrading.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2022-24822?

4 open source packages ship an affected version, including @podium/proxy and @podium/layout. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@podium/proxy` | npm | All versions | 4.2.74 |
| `@podium/proxy` | npm | All versions | 4.2.74 |
| `@podium/layout` | npm | All versions | 4.6.110 |
| `@podium/layout` | npm | All versions | 4.6.110 |

Products: Finn Podium Layout, Finn Podium Proxy.

## How do I fix CVE-2022-24822?

Upgrade @podium/proxy to 4.2.74 or later.

## Is CVE-2022-24822 being exploited?

There is no known exploitation of CVE-2022-24822 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24822 and fix it if it is affected.

What it is: CVE-2022-24822 is a high-severity denial of service vulnerability in podium-lib proxy, published on 6 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24822 in the wild and no public exploit code.

Affected packages and fixed versions:
- @podium/proxy (npm): affected all versions; fixed in 4.2.74
- @podium/proxy (npm): affected all versions; fixed in 4.2.74
- @podium/layout (npm): affected all versions; fixed in 4.6.110
- @podium/layout (npm): affected all versions; fixed in 4.6.110

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24822/ (Markdown: https://insights.sbomify.com/CVE-2022-24822/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24822
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24822
- OSV: https://osv.dev/vulnerability/CVE-2022-24822

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24822/
Summaries are generated and may contain mistakes; the official description above is the record.
