# CVE-2022-24823: Local Information Disclosure Vulnerability in io.netty:netty-codec-http

> Local attackers can read sensitive files from the system temporary directory when Netty multipart uploads are stored on disk in shared environments.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 May 2022
- **Updated:** 22 Apr 2025
- **Also known as:** CLEANSTART-2026-RS84858, CLEANSTART-2026-RV50015, CLEANSTART-2026-ZU77357, DEBIAN-CVE-2022-24823, GHSA-269q-hmxg-m83q, MINI-wm25-3px2-82fm, OESA-2025-2149, OESA-2025-2150, OESA-2025-2151, OESA-2025-2152, OESA-2025-2153, OESA-2025-2286, UBUNTU-CVE-2022-24823

## What is CVE-2022-24823?

CVE-2022-24823 is a medium-severity vulnerability in Netapp Active Iq Unified Manager, published on 6 May 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Netty is an open-source, asynchronous event-driven network application framework. The package `io.netty:netty-codec-http` prior to version 4.1.77.Final contains an insufficient fix for CVE-2021-21290. When Netty's multipart decoders are used local information disclosure can occur via the local system temporary directory if temporary storing uploads on the disk is enabled. This only impacts applications running on Java version 6 and lower. Additionally, this vulnerability impacts code running on Unix-like systems, and very old versions of Mac OSX and Windows as they all share the system temporary directory between all users. Version 4.1.77.Final contains a patch for this vulnerability. As a workaround, specify one's own `java.io.tmpdir` when starting the JVM or use DefaultHttpDataFactory.setBaseDir(...) to set the directory to something that is only readable by the current user.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere), CWE-379 (Creation of Temporary File in Directory with Insecure Permissions), CWE-378 (Creation of Temporary File With Insecure Permissions)

## Which versions are affected by CVE-2022-24823?

2 open source packages ship an affected version, including io.netty:netty-codec-http. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-codec-http` | Maven | All versions | 4.1.77.Final |
| `io.netty:netty-codec-http` | Maven | All versions | 4.1.77.Final |

Products: Netapp Active Iq Unified Manager, Netapp Oncommand Workflow Automation, Netapp Snapcenter, Netty Netty, Oracle Financial Services Crime and Compliance Management Studio.

## How do I fix CVE-2022-24823?

Upgrade io.netty:netty-codec-http to 4.1.77.Final or later.

## Is CVE-2022-24823 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24823 exists.

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2022-31692](https://insights.sbomify.com/CVE-2022-31692/): Spring Security authorization rules can be bypassed via forward or include dispatcher types (critical 9.8)
- [CVE-2022-2526](https://insights.sbomify.com/CVE-2022-2526/): Use after free in systemd-resolved (critical 9.8)
- [CVE-2022-22978](https://insights.sbomify.com/CVE-2022-22978/): Authorization bypass in Spring Security (critical 9.8)
- [CVE-2021-22931](https://insights.sbomify.com/CVE-2021-22931/): Code injection in Node (critical 9.8)
- [CVE-2018-2938](https://insights.sbomify.com/CVE-2018-2938/): Code injection in Java (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24823 and fix it if it is affected.

What it is: CVE-2022-24823 is a medium-severity vulnerability in Netapp Active Iq Unified Manager, published on 6 May 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24823 exists.

Affected packages and fixed versions:
- io.netty:netty-codec-http (Maven): affected all versions; fixed in 4.1.77.Final
- io.netty:netty-codec-http (Maven): affected all versions; fixed in 4.1.77.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24823/ (Markdown: https://insights.sbomify.com/CVE-2022-24823/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24823
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24823
- OSV: https://osv.dev/vulnerability/CVE-2022-24823

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24823/
Summaries are generated and may contain mistakes; the official description above is the record.
