# CVE-2022-24825: Smokescreen SSRF via deny list bypass

> Attackers can bypass the deny list in Smokescreen proxy by manipulating URL formatting, allowing unauthorized access to blocked resources.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Apr 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-gcj7-j438-hjj2, GO-2022-0429

## What is CVE-2022-24825?

CVE-2022-24825 is a medium-severity server-side request forgery vulnerability in stripe smokescreen, published on 19 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Smokescreen is a simple HTTP proxy that fogs over naughty URLs. The primary use case for Smokescreen is to prevent server-side request forgery (SSRF) attacks in which external attackers leverage the behavior of applications to connect to or scan internal infrastructure. Smokescreen also offers an option to deny access to additional (e.g., external) URLs by way of a deny list. There was an issue in Smokescreen that made it possible to bypass the deny list feature by appending a dot to the end of user-supplied URLs, or by providing input in a different letter case. Recommended to upgrade Smokescreen to version 0.0.3 or later.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2022-24825?

3 open source packages ship an affected version, including github.com/stripe/smokescreen. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/stripe/smokescreen` | Go | All versions | 0.0.3 |
| `github.com/stripe/smokescreen` | Go | All versions | 0.0.3 |
| `github.com/stripe/smokescreen` | Go | All versions | 0.0.3 |

Products: Stripe Smokescreen.

## How do I fix CVE-2022-24825?

Upgrade github.com/stripe/smokescreen to 0.0.3 or later.

## Is CVE-2022-24825 being exploited?

There is no known exploitation of CVE-2022-24825 in the wild and no public exploit code.

## Other vulnerabilities in stripe smokescreen

- [CVE-2022-29188](https://insights.sbomify.com/CVE-2022-29188/): Smokescreen SSRF via deny list bypass (square brackets) in Smokescreen (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24825 and fix it if it is affected.

What it is: CVE-2022-24825 is a medium-severity server-side request forgery vulnerability in stripe smokescreen, published on 19 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24825 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/stripe/smokescreen (Go): affected all versions; fixed in 0.0.3
- github.com/stripe/smokescreen (Go): affected all versions; fixed in 0.0.3
- github.com/stripe/smokescreen (Go): affected all versions; fixed in 0.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24825/ (Markdown: https://insights.sbomify.com/CVE-2022-24825/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24825
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24825
- OSV: https://osv.dev/vulnerability/CVE-2022-24825

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24825/
Summaries are generated and may contain mistakes; the official description above is the record.
