{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-24829 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2022-24829 yet. Limit exposure of the affected software until one is available.","what":"CVE-2022-24829 is a high-severity missing authorization vulnerability in garden-io garden, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24829 and fix it if it is affected.\n\nWhat it is: CVE-2022-24829 is a high-severity missing authorization vulnerability in garden-io garden, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-24829 in the wild and no public exploit code.\n\nAffected product: garden-io garden. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24829/ (Markdown: https://insights.sbomify.com/CVE-2022-24829/index.md)","id":"CVE-2022-24829","markdown":"https://insights.sbomify.com/CVE-2022-24829/index.md","name":"CVE-2022-24829","record":{"aliases":["GHSA-f5f3-qrqw-2vqf"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Kubernetes automation platform","requires_auth":"none","summary":"Attackers can access sensitive configuration and credentials via unauthenticated API endpoints on the local dashboard server.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"garden","vendor":"garden"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"}],"description":"Garden is an automation platform for Kubernetes development and testing. In versions prior to 0.12.39 multiple endpoints did not require authentication. In some operating modes this allows for an attacker to gain access to the application erroneously. The configuration is leaked through the /api endpoint on the local server that is responsible for serving the Garden dashboard. At the moment, this server is accessible to 0.0.0.0 which makes it accessible to anyone on the same network (or anyone on the internet if they are on a public, static IP). This may lead to the ability to compromise credentials, secrets or environment variables. Users are advised to upgrade to version 0.12.39 as soon as possible. Users unable to upgrade should use a firewall blocking access to port 9777 from all untrusted network machines.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Missing authentication in Garden","id":"CVE-2022-24829","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2022"},"n_packages":0,"n_references":2,"next":{"headline":"Path Traversal in OpenClinica","id":"CVE-2022-24830"},"packages":[],"prev":{"headline":"Missing input validation can lead to command execution in composer","id":"CVE-2022-24828"},"products":["garden"],"published":"2022-04-11","related":[{"cvss_score":8.3,"headline":"Arbitrary code execution vulnerability when using shared Kubernetes cluster","id":"CVE-2023-44392","kev_date_added":null,"published":"2023-10-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["garden-io"]},"summary":"Attackers can access sensitive configuration and credentials via unauthenticated API endpoints on the local dashboard server.","url":"https://insights.sbomify.com/CVE-2022-24829/"}