# CVE-2022-24829: Missing authentication in Garden

> Attackers can access sensitive configuration and credentials via unauthenticated API endpoints on the local dashboard server.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Apr 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-f5f3-qrqw-2vqf

## What is CVE-2022-24829?

CVE-2022-24829 is a high-severity missing authorization vulnerability in garden-io garden, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Garden is an automation platform for Kubernetes development and testing. In versions prior to 0.12.39 multiple endpoints did not require authentication. In some operating modes this allows for an attacker to gain access to the application erroneously. The configuration is leaked through the /api endpoint on the local server that is responsible for serving the Garden dashboard. At the moment, this server is accessible to 0.0.0.0 which makes it accessible to anyone on the same network (or anyone on the internet if they are on a public, static IP). This may lead to the ability to compromise credentials, secrets or environment variables. Users are advised to upgrade to version 0.12.39 as soon as possible. Users unable to upgrade should use a firewall blocking access to port 9777 from all untrusted network machines.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2022-24829?

It affects 1 product.


Products: Garden Garden.

## How do I fix CVE-2022-24829?

No fix has been published for CVE-2022-24829 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-24829 being exploited?

There is no known exploitation of CVE-2022-24829 in the wild and no public exploit code.

## Other vulnerabilities in garden-io garden

- [CVE-2023-44392](https://insights.sbomify.com/CVE-2023-44392/): Arbitrary code execution vulnerability when using shared Kubernetes cluster (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24829 and fix it if it is affected.

What it is: CVE-2022-24829 is a high-severity missing authorization vulnerability in garden-io garden, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24829 in the wild and no public exploit code.

Affected product: garden-io garden. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24829/ (Markdown: https://insights.sbomify.com/CVE-2022-24829/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24829
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24829
- OSV: https://osv.dev/vulnerability/CVE-2022-24829

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24829/
Summaries are generated and may contain mistakes; the official description above is the record.
