{"answers":{"affected":"2 open source packages ship an affected version, including privatebin/privatebin. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24833 exists.","fix":"Upgrade privatebin/privatebin to 1.4.0 or later.","what":"CVE-2022-24833 is a high-severity cross-site scripting vulnerability in PrivateBin, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-24833 and fix it if it is affected.\n\nWhat it is: CVE-2022-24833 is a high-severity cross-site scripting vulnerability in PrivateBin, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24833 exists.\n\nAffected packages and fixed versions:\n- privatebin/privatebin (Packagist): affected from 0.21; fixed in 1.4.0\n- privatebin/privatebin (Packagist): affected from 0.21; fixed in 1.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24833/ (Markdown: https://insights.sbomify.com/CVE-2022-24833/index.md)","id":"CVE-2022-24833","markdown":"https://insights.sbomify.com/CVE-2022-24833/index.md","name":"CVE-2022-24833","record":{"aliases":["GHSA-cqcc-mm6x-vmvw"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"PrivateBin pastebin","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript via crafted SVG attachments in PrivateBin pastes if the instance lacks a proper Content Security Policy.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"privatebin","vendor":"privatebin"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"PrivateBin is minimalist, open source online pastebin clone where the server has zero knowledge of pasted data. In PrivateBin \u003c v1.4.0 a cross-site scripting (XSS) vulnerability was found. The vulnerability is present in all versions from v0.21 of the project, which was at the time still called ZeroBin. The issue is caused by the fact that SVGs can contain JavaScript. This can allow an attacker to execute code, if the user opens a paste with a specifically crafted SVG attachment, and interacts with the preview image and the instance isn't protected by an appropriate content security policy. Users are advised to either upgrade to version 1.4.0 or to ensure the content security policy of their instance is set correctly.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Persistent Cross-site Scripting (XSS) vulnerability in PrivateBin","id":"CVE-2022-24833","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Heap overflow issue with the Lua cjson library used by Redis","id":"CVE-2022-24834"},"packages":[{"ecosystem":"Packagist","fixed":["1.4.0"],"introduced":["0.21"],"last_affected":[],"package":"privatebin/privatebin","purl":null,"source":"GHSA-cqcc-mm6x-vmvw"},{"ecosystem":"Packagist","fixed":["1.4.0"],"introduced":["0.21"],"last_affected":[],"package":"privatebin/privatebin","purl":"pkg:composer/privatebin/privatebin","source":"GHSA-cqcc-mm6x-vmvw"}],"prev":{"headline":"Bundled ldap-authentication-plugin fails to neutralise LDAP special elements in usernames","id":"CVE-2022-24832"},"products":["PrivateBin"],"published":"2022-04-11","related":[{"cvss_score":6.1,"headline":"Persistent XSS vulnerability in filename of attached file in PrivateBin","id":"CVE-2020-5223","kev_date_added":null,"published":"2020-01-23"},{"cvss_score":3.9,"headline":"PrivateBin vulnerable to malicious filename use for self-XSS / HTML injection locally for users","id":"CVE-2025-64711","kev_date_added":null,"published":"2025-11-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["PrivateBin"]},"summary":"Attackers can execute arbitrary JavaScript via crafted SVG attachments in PrivateBin pastes if the instance lacks a proper Content Security Policy.","url":"https://insights.sbomify.com/CVE-2022-24833/"}