# CVE-2022-24836: Inefficient Regular Expression Complexity in Nokogiri

> An attacker can cause a denial of service in applications using Nokogiri by submitting HTML documents that trigger excessive backtracking in encoding detection regexes.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2022
- **Updated:** 3 Sep 2024
- **Also known as:** DEBIAN-CVE-2022-24836, DLA-3003-1, DLA-3868-1, GHSA-crjr-9rc5-ghw8, MGASA-2022-0164, OESA-2022-1644, UBUNTU-CVE-2022-24836

## What is CVE-2022-24836?

CVE-2022-24836 is a high-severity denial of service vulnerability in Apple Macos, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nokogiri is an open source XML and HTML library for Ruby. Nokogiri `< v1.13.4` contains an inefficient regular expression that is susceptible to excessive backtracking when attempting to detect encoding in HTML documents. Users are advised to upgrade to Nokogiri `>= 1.13.4`. There are no known workarounds for this issue.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2022-24836?

2 open source packages ship an affected version, including nokogiri. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nokogiri` | RubyGems | All versions | 1.13.4 |
| `nokogiri` | RubyGems | All versions | 1.13.4 |

Products: Apple Macos, Debian Debian Linux, Fedoraproject Fedora, Nokogiri Nokogiri.

## How do I fix CVE-2022-24836?

Upgrade nokogiri to 1.13.4 or later.

## Is CVE-2022-24836 being exploited?

There is no known exploitation of CVE-2022-24836 in the wild and no public exploit code.

## Other vulnerabilities in Apple Macos

- [CVE-2026-65400](https://insights.sbomify.com/CVE-2026-65400/): Apple macOS Improper Authentication (critical 9.8, exploited in the wild)
- [CVE-2024-44146](https://insights.sbomify.com/CVE-2024-44146/): Security feature bypass in macOS (critical 10.0)
- [CVE-2024-44148](https://insights.sbomify.com/CVE-2024-44148/): Security feature bypass in macOS (critical 10.0)
- [CVE-2023-38586](https://insights.sbomify.com/CVE-2023-38586/): Security feature bypass in macOS (critical 10.0)
- [CVE-2023-40455](https://insights.sbomify.com/CVE-2023-40455/): Security feature bypass in macOS (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24836 and fix it if it is affected.

What it is: CVE-2022-24836 is a high-severity denial of service vulnerability in Apple Macos, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24836 in the wild and no public exploit code.

Affected packages and fixed versions:
- nokogiri (RubyGems): affected all versions; fixed in 1.13.4
- nokogiri (RubyGems): affected all versions; fixed in 1.13.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24836/ (Markdown: https://insights.sbomify.com/CVE-2022-24836/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24836
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24836
- OSV: https://osv.dev/vulnerability/CVE-2022-24836

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24836/
Summaries are generated and may contain mistakes; the official description above is the record.
