{"answers":{"affected":"2 open source packages ship an affected version, including org.nokogiri:nekohtml. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-24839 in the wild and no public exploit code.","fix":"Upgrade org.nokogiri:nekohtml to 1.9.22.noko2 or later.","what":"CVE-2022-24839 is a high-severity denial of service vulnerability in Oracle Weblogic Server, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24839 and fix it if it is affected.\n\nWhat it is: CVE-2022-24839 is a high-severity denial of service vulnerability in Oracle Weblogic Server, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-24839 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.nokogiri:nekohtml (Maven): affected all versions; fixed in 1.9.22.noko2\n- org.nokogiri:nekohtml (Maven): affected all versions; fixed in 1.9.22.noko2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24839/ (Markdown: https://insights.sbomify.com/CVE-2022-24839/index.md)","id":"CVE-2022-24839","markdown":"https://insights.sbomify.com/CVE-2022-24839/index.md","name":"CVE-2022-24839","record":{"aliases":["CLSA-2026-1770682159","DEBIAN-CVE-2022-24839","GHSA-9849-p7jc-9rmv","OESA-2022-1636","UBUNTU-CVE-2022-24839"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Java HTML parser","requires_auth":"none","summary":"Attackers can cause denial of service by triggering an OutOfMemoryError in the Nokogiri fork of the NekoHTML parser via ill-formed HTML.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"nekohtml","vendor":"nekohtml_project"},{"product":"weblogic_server","vendor":"oracle"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"org.cyberneko.html is an html parser written in Java. The fork of `org.cyberneko.html` used by Nokogiri (Rubygem) raises a `java.lang.OutOfMemoryError` exception when parsing ill-formed HTML markup. Users are advised to upgrade to `\u003e= 1.9.22.noko2`. Note: The upstream library `org.cyberneko.html` is no longer maintained. Nokogiri uses its own fork of this library located at https://github.com/sparklemotion/nekohtml and this CVE applies only to that fork. Other forks of nekohtml may have a similar vulnerability.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Uncontrolled Resource Consumption in org.cyberneko.html (nokogiri fork)","id":"CVE-2022-24839","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"oracle:weblogic_server","products":["oracle:weblogic_server"],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in django-s3file","id":"CVE-2022-24840"},"packages":[{"ecosystem":"Maven","fixed":["1.9.22.noko2"],"introduced":["0"],"last_affected":[],"package":"org.nokogiri:nekohtml","purl":null,"source":"GHSA-9849-p7jc-9rmv"},{"ecosystem":"Maven","fixed":["1.9.22.noko2"],"introduced":["0"],"last_affected":[],"package":"org.nokogiri:nekohtml","purl":"pkg:maven/org.nokogiri/nekohtml","source":"GHSA-9849-p7jc-9rmv"}],"prev":{"headline":"Command Injection in Appointment Emails for Nextcloud Calendar","id":"CVE-2022-24838"},"products":["nekohtml"],"published":"2022-04-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["sparklemotion"]},"summary":"Attackers can cause denial of service by triggering an OutOfMemoryError in the Nokogiri fork of the NekoHTML parser via ill-formed HTML.","url":"https://insights.sbomify.com/CVE-2022-24839/"}