# CVE-2022-24839: Uncontrolled Resource Consumption in org.cyberneko.html (nokogiri fork)

> Attackers can cause denial of service by triggering an OutOfMemoryError in the Nokogiri fork of the NekoHTML parser via ill-formed HTML.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2022
- **Updated:** 23 Apr 2025
- **Also known as:** CLSA-2026-1770682159, DEBIAN-CVE-2022-24839, GHSA-9849-p7jc-9rmv, OESA-2022-1636, UBUNTU-CVE-2022-24839

## What is CVE-2022-24839?

CVE-2022-24839 is a high-severity denial of service vulnerability in Oracle Weblogic Server, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

org.cyberneko.html is an html parser written in Java. The fork of `org.cyberneko.html` used by Nokogiri (Rubygem) raises a `java.lang.OutOfMemoryError` exception when parsing ill-formed HTML markup. Users are advised to upgrade to `>= 1.9.22.noko2`. Note: The upstream library `org.cyberneko.html` is no longer maintained. Nokogiri uses its own fork of this library located at https://github.com/sparklemotion/nekohtml and this CVE applies only to that fork. Other forks of nekohtml may have a similar vulnerability.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-24839?

2 open source packages ship an affected version, including org.nokogiri:nekohtml. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.nokogiri:nekohtml` | Maven | All versions | 1.9.22.noko2 |
| `org.nokogiri:nekohtml` | Maven | All versions | 1.9.22.noko2 |

Products: Nekohtml Project Nekohtml, Oracle Weblogic Server.

## How do I fix CVE-2022-24839?

Upgrade org.nokogiri:nekohtml to 1.9.22.noko2 or later.

## Is CVE-2022-24839 being exploited?

There is no known exploitation of CVE-2022-24839 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24839 and fix it if it is affected.

What it is: CVE-2022-24839 is a high-severity denial of service vulnerability in Oracle Weblogic Server, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24839 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.nokogiri:nekohtml (Maven): affected all versions; fixed in 1.9.22.noko2
- org.nokogiri:nekohtml (Maven): affected all versions; fixed in 1.9.22.noko2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24839/ (Markdown: https://insights.sbomify.com/CVE-2022-24839/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24839
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24839
- OSV: https://osv.dev/vulnerability/CVE-2022-24839

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24839/
Summaries are generated and may contain mistakes; the official description above is the record.
