# CVE-2022-24840: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in django-s3file


- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 6 Jun 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-4w8f-hjm9-xwgf, PYSEC-2022-208

## What is CVE-2022-24840?

CVE-2022-24840 is a critical vulnerability in codingjoe django-s3file, published on 6 Jun 2022. 

### Official description

django-s3file is a lightweight file upload input for Django and Amazon S3 . In versions prior to 5.5.1 it was possible to traverse the entire AWS S3 bucket and in most cases to access or delete files. If the `AWS_LOCATION` setting was set, traversal was limited to that location only. The issue was discovered by the maintainer. There were no reports of the vulnerability being known to or exploited by a third party, prior to the release of the patch. The vulnerability has been fixed in version 5.5.1 and above. There is no feasible workaround. We must urge all users to immediately updated to a patched version.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-24840?

3 open source packages ship an affected version, including django-s3file. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django-s3file` | PyPI | All versions | 5.5.1 |
| `django-s3file` | PyPI | All versions | 5.5.1 |
| `django-s3file` | PyPI | All versions | 5.5.1 |

Products: Django-S3file Project Django-S3file.

## How do I fix CVE-2022-24840?

Upgrade django-s3file to 5.5.1 or later.

## Is CVE-2022-24840 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24840 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24840 and fix it if it is affected.

What it is: CVE-2022-24840 is a critical vulnerability in codingjoe django-s3file, published on 6 Jun 2022. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24840 exists.

Affected packages and fixed versions:
- django-s3file (PyPI): affected all versions; fixed in 5.5.1
- django-s3file (PyPI): affected all versions; fixed in 5.5.1
- django-s3file (PyPI): affected all versions; fixed in 5.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24840/ (Markdown: https://insights.sbomify.com/CVE-2022-24840/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24840
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24840
- OSV: https://osv.dev/vulnerability/CVE-2022-24840

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24840/
Summaries are generated and may contain mistakes; the official description above is the record.
