# CVE-2022-24845: Integer bounds error in Vyper

> Attackers can exploit missing integer bounds validation in Vyper to cause incorrect contract behavior and data corruption.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Apr 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-j2x6-9323-fp7h, PYSEC-2022-198

## What is CVE-2022-24845?

CVE-2022-24845 is a high-severity vulnerability in vyperlang vyper, published on 13 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Vyper is a pythonic Smart Contract Language for the ethereum virtual machine. In affected versions, the return of `<iface>.returns_int128()` is not validated to fall within the bounds of `int128`. This issue can result in a misinterpretation of the integer value and lead to incorrect behavior. As of v0.3.0, `<iface>.returns_int128()` is validated in simple expressions, but not complex expressions. Users are advised to upgrade. There is no known workaround for this issue.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2022-24845?

3 open source packages ship an affected version, including vyper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vyper` | PyPI | All versions | 0.3.2 |
| `vyper` | PyPI | All versions | 0.3.2 |
| `vyper` | PyPI | All versions | 0.3.2 |

Products: Vyperlang Vyper.

## How do I fix CVE-2022-24845?

Upgrade vyper to 0.3.2 or later.

## Is CVE-2022-24845 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24845 exists.

## Other vulnerabilities in vyperlang vyper

- [CVE-2024-24563](https://insights.sbomify.com/CVE-2024-24563/): Vyper array negative index vulnerability (critical 9.8)
- [CVE-2024-24561](https://insights.sbomify.com/CVE-2024-24561/): Vyper bounds check on built-in `slice()` function can be overflowed (critical 9.8)
- [CVE-2023-39363](https://insights.sbomify.com/CVE-2023-39363/): Vyper incorrectly allocated named re-entrancy locks (critical 9.1)
- [CVE-2022-29255](https://insights.sbomify.com/CVE-2022-29255/): Multiple evaluation of contract address in call in vyper (high 8.2)
- [CVE-2023-42443](https://insights.sbomify.com/CVE-2023-42443/): Vyper vulnerable to memory corruption in certain builtins utilizing `msize` (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24845 and fix it if it is affected.

What it is: CVE-2022-24845 is a high-severity vulnerability in vyperlang vyper, published on 13 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24845 exists.

Affected packages and fixed versions:
- vyper (PyPI): affected all versions; fixed in 0.3.2
- vyper (PyPI): affected all versions; fixed in 0.3.2
- vyper (PyPI): affected all versions; fixed in 0.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24845/ (Markdown: https://insights.sbomify.com/CVE-2022-24845/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24845
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24845
- OSV: https://osv.dev/vulnerability/CVE-2022-24845

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24845/
Summaries are generated and may contain mistakes; the official description above is the record.
