CVE-2022-24858 Default redirect callback vulnerable to open redirects

Medium 6.1 Published Updated

Attackers can exploit default redirect callbacks to redirect users to malicious sites, requiring an upgrade or callback configuration fix.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-24858?

CVE-2022-24858 is a medium-severity vulnerability in nextauthjs next-auth, published on 19 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

next-auth v3 users before version 3.29.2 are impacted. next-auth version 4 users before version 4.3.2 are also impacted. Upgrading to 3.29.2 or 4.3.2 will patch this vulnerability. If you are not able to upgrade for any reason, you can add a configuration to your callbacks option. If you already have a `redirect` callback, make sure that you match the incoming `url` origin against the `baseUrl`.

Weakness: CWE-601, CWE-290

Which versions are affected by CVE-2022-24858?

4 open source packages ship an affected version, including next-auth. It affects 1 product.

PackageAffectedFixed in
next-auth npmAll versions3.29.2
next-auth npmAll versions3.29.2
next-auth npmFrom 4.0.04.3.2
next-auth npmFrom 4.0.04.3.2

Products include Nextauth.js Next-Auth.

How do I fix CVE-2022-24858?

Upgrade next-auth to a fixed version for your release line: 3.29.2 or 4.3.2.

Is CVE-2022-24858 being exploited?

There is no known exploitation of CVE-2022-24858 in the wild and no public exploit code.

Sources

Also known as GHSA-f9wg-5f46-cjmw.

Is CVE-2022-24858 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free