# CVE-2022-24859: Manipulated inline images can cause Infinite Loop in PyPDF2

> An attacker can cause a denial of service via an infinite loop in PyPDF2 by crafting a malicious PDF with manipulated inline images.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Apr 2022
- **Updated:** 22 Apr 2025
- **Also known as:** DEBIAN-CVE-2022-24859, DLA-3039-1, DLA-3451-1, GHSA-xcjx-m2pj-8g79, MGASA-2022-0224, PYSEC-2022-194, UBUNTU-CVE-2022-24859, USN-6176-1, openSUSE-SU-2024:0366-1

## What is CVE-2022-24859?

CVE-2022-24859 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 18 Apr 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

PyPDF2 is an open source python PDF library capable of splitting, merging, cropping, and transforming the pages of PDF files. In versions prior to 1.27.5 an attacker who uses this vulnerability can craft a PDF which leads to an infinite loop if the PyPDF2 if the code attempts to get the content stream. The reason is that the last while-loop in `ContentStream._readInlineImage` only terminates when it finds the `EI` token, but never actually checks if the stream has already ended. This issue has been resolved in version `1.27.5`. Users unable to upgrade should validate and PDFs prior to iterating over their content stream.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2022-24859?

3 open source packages ship an affected version, including pypdf2 and PyPDF2. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pypdf2` | PyPI | All versions | 1.27.5 |
| `pypdf2` | PyPI | All versions | 1.27.5 |
| `PyPDF2` | PyPI | All versions | 1.27.5 |
| `python-PyPDF2` | SUSE:Package Hub 15 SP6 | All versions | 1.26.0-bp156.4.3.1 |
| `python-PyPDF2` | openSUSE:Leap 15.6 | All versions | 1.26.0-bp156.4.3.1 |

Products: Debian Debian Linux, Pypdf2 Project Pypdf2.

## How do I fix CVE-2022-24859?

Upgrade pypdf2 to 1.27.5 or later.

## Is CVE-2022-24859 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24859 exists.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24859 and fix it if it is affected.

What it is: CVE-2022-24859 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 18 Apr 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24859 exists.

Affected packages and fixed versions:
- pypdf2 (PyPI): affected all versions; fixed in 1.27.5
- pypdf2 (PyPI): affected all versions; fixed in 1.27.5
- PyPDF2 (PyPI): affected all versions; fixed in 1.27.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24859/ (Markdown: https://insights.sbomify.com/CVE-2022-24859/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24859
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24859
- OSV: https://osv.dev/vulnerability/CVE-2022-24859

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24859/
Summaries are generated and may contain mistakes; the official description above is the record.
