# CVE-2022-24865: Improper access control in humhub

> Users forced to change passwords can access other users' data due to improper access control in HumHub.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 20 Apr 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-2h35-f226-3f57

## What is CVE-2022-24865?

CVE-2022-24865 is a medium-severity missing authorization vulnerability in humhub, published on 20 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

HumHub is an Open Source Enterprise Social Network. In affected versions users who are forced to change their password by an administrator may retrieve other users' data. This issue has been resolved by commit `eb83de20`. It is recommended that the HumHub is upgraded to 1.11.0, 1.10.4 or 1.9.4. There are no known workarounds for this issue.

Weakness: CWE-863 (Incorrect Authorization), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-24865?

It affects 1 product.


Products: Humhub Humhub.

## How do I fix CVE-2022-24865?

No fix has been published for CVE-2022-24865 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-24865 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24865 exists.

## Other vulnerabilities in humhub

- [CVE-2014-9528](https://insights.sbomify.com/CVE-2014-9528/): SQL injection in n/a (high 7.5)
- [CVE-2025-64442](https://insights.sbomify.com/CVE-2025-64442/): HumHub is vulnerable to XSS through its Meta Search component (high 7.1)
- [CVE-2026-29048](https://insights.sbomify.com/CVE-2026-29048/): HumHub: XSS in Button component (medium 6.9)
- [CVE-2024-52043](https://insights.sbomify.com/CVE-2024-52043/): User enumeration in HubHub (medium 6.9)
- [CVE-2021-43847](https://insights.sbomify.com/CVE-2021-43847/): Authorization Bypass in Space Invite in HumHub (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24865 and fix it if it is affected.

What it is: CVE-2022-24865 is a medium-severity missing authorization vulnerability in humhub, published on 20 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24865 exists.

Affected product: humhub. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24865/ (Markdown: https://insights.sbomify.com/CVE-2022-24865/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24865
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24865
- OSV: https://osv.dev/vulnerability/CVE-2022-24865

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24865/
Summaries are generated and may contain mistakes; the official description above is the record.
