CVE-2022-24871 Server-Side Request Forgery (SSRF) in Shopware

High 7.2 Published Updated

An attacker can exploit the Admin SDK to read or update internal resources via Server-Side Request Forgery in Shopware.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-24871?

CVE-2022-24871 is a high-severity server-side request forgery vulnerability in Shopware Shopware, published on 20 Apr 2022. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Shopware is an open commerce platform based on Symfony Framework and Vue. In affected versions an attacker can abuse the Admin SDK functionality on the server to read or update internal resources. Users are advised to update to the current version 6.4.10.1. For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. There are no known workarounds for this issue.

Weakness: CWE-918

Which versions are affected by CVE-2022-24871?

4 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.

PackageAffectedFixed in
shopware/core PackagistAll versions6.4.10.1
shopware/core PackagistAll versions6.4.10.1
shopware/platform PackagistAll versions6.4.10.1
shopware/platform PackagistAll versions6.4.10.1

Products include Shopware Shopware.

How do I fix CVE-2022-24871?

Upgrade shopware/core to 6.4.10.1 or later.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2022-24871 being exploited?

There is no known exploitation of CVE-2022-24871 in the wild and no public exploit code.

All Shopware Shopware vulnerabilities

Sources

Also known as GHSA-7gm7-8q8v-9gf2.

Is CVE-2022-24871 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free