{"answers":{"affected":"4 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-24871 in the wild and no public exploit code.","fix":"Upgrade shopware/core to 6.4.10.1 or later.","what":"CVE-2022-24871 is a high-severity server-side request forgery vulnerability in Shopware Shopware, published on 20 Apr 2022. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24871 and fix it if it is affected.\n\nWhat it is: CVE-2022-24871 is a high-severity server-side request forgery vulnerability in Shopware Shopware, published on 20 Apr 2022. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-24871 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- shopware/core (Packagist): affected all versions; fixed in 6.4.10.1\n- shopware/core (Packagist): affected all versions; fixed in 6.4.10.1\n- shopware/platform (Packagist): affected all versions; fixed in 6.4.10.1\n- shopware/platform (Packagist): affected all versions; fixed in 6.4.10.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24871/ (Markdown: https://insights.sbomify.com/CVE-2022-24871/index.md)","id":"CVE-2022-24871","markdown":"https://insights.sbomify.com/CVE-2022-24871/index.md","name":"CVE-2022-24871","record":{"aliases":["GHSA-7gm7-8q8v-9gf2"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Shopware e-commerce platform","requires_auth":"high_privilege","summary":"An attacker can exploit the Admin SDK to read or update internal resources via Server-Side Request Forgery in Shopware.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"shopware","vendor":"shopware"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Shopware is an open commerce platform based on Symfony Framework and Vue. In affected versions an attacker can abuse the Admin SDK functionality on the server to read or update internal resources. Users are advised to update to the current version 6.4.10.1. For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. There are no known workarounds for this issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Server-Side Request Forgery (SSRF) in Shopware","id":"CVE-2022-24871","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"shopware:shopware","products":["shopware:shopware"],"type":"ssrf","year":"2022"},"n_packages":4,"n_references":3,"next":{"headline":"Improper Access Control in shopware","id":"CVE-2022-24872"},"packages":[{"ecosystem":"Packagist","fixed":["6.4.10.1"],"introduced":["0"],"last_affected":[],"package":"shopware/core","purl":null,"source":"GHSA-7gm7-8q8v-9gf2"},{"ecosystem":"Packagist","fixed":["6.4.10.1"],"introduced":["0"],"last_affected":[],"package":"shopware/core","purl":"pkg:composer/shopware/core","source":"GHSA-7gm7-8q8v-9gf2"},{"ecosystem":"Packagist","fixed":["6.4.10.1"],"introduced":["0"],"last_affected":[],"package":"shopware/platform","purl":null,"source":"GHSA-7gm7-8q8v-9gf2"},{"ecosystem":"Packagist","fixed":["6.4.10.1"],"introduced":["0"],"last_affected":[],"package":"shopware/platform","purl":"pkg:composer/shopware/platform","source":"GHSA-7gm7-8q8v-9gf2"}],"prev":{"headline":"Stored Cross-site Scripting in Combodo iTop","id":"CVE-2022-24870"},"products":["platform"],"published":"2022-04-20","related":[{"cvss_score":10,"headline":"Improper Control of Generation of Code in Twig rendered views in shopware","id":"CVE-2023-22731","kev_date_added":null,"published":"2023-01-17"},{"cvss_score":9.8,"headline":"Shopware RCE Vulnerability","id":"CVE-2016-3109","kev_date_added":null,"published":"2017-04-21"},{"cvss_score":9.3,"headline":"Blind SQL-injection in DAL aggregations in Shopware","id":"CVE-2024-22406","kev_date_added":null,"published":"2024-01-16"},{"cvss_score":9.1,"headline":"Leak of information via Store-API","id":"CVE-2021-32711","kev_date_added":null,"published":"2021-06-24"},{"cvss_score":8.9,"headline":"Shopware unauthenticated data extraction possible through store-api.order endpoint","id":"CVE-2026-31887","kev_date_added":null,"published":"2026-03-11"},{"cvss_score":8.9,"headline":"Shopware has a potential take over of app credentials","id":"CVE-2026-31889","kev_date_added":null,"published":"2026-03-11"},{"cvss_score":8.8,"headline":"Improper Control of Generation of Code in Twig Rendered Views in Shopware","id":"CVE-2023-2017","kev_date_added":null,"published":"2023-04-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["shopware"]},"summary":"An attacker can exploit the Admin SDK to read or update internal resources via Server-Side Request Forgery in Shopware.","url":"https://insights.sbomify.com/CVE-2022-24871/"}