CVE-2022-24872 Improper Access Control in shopware

High 8.1 Published Updated

Attackers can exploit improper access control to use admin API permissions within normal user sessions, potentially escalating privileges or accessing sensitive data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-24872?

CVE-2022-24872 is a high-severity missing authorization vulnerability in Shopware Shopware, published on 20 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Shopware is an open commerce platform based on Symfony Framework and Vue. Permissions set to sales channel context by admin-api are still usable within normal user session. Users are advised to update to the current version 6.4.10.1. For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. There are no known workarounds for this issue.

Weakness: CWE-732

Which versions are affected by CVE-2022-24872?

4 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.

PackageAffectedFixed in
shopware/core PackagistAll versions6.4.10.1
shopware/core PackagistAll versions6.4.10.1
shopware/platform PackagistAll versions6.4.10.1
shopware/platform PackagistAll versions6.4.10.1

Products include Shopware Shopware.

How do I fix CVE-2022-24872?

Upgrade shopware/core to 6.4.10.1 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2022-24872 being exploited?

There is no known exploitation of CVE-2022-24872 in the wild and no public exploit code.

All Shopware Shopware vulnerabilities

Sources

Also known as GHSA-9wrv-g75h-8ccc.

Is CVE-2022-24872 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free