# CVE-2022-24872: Improper Access Control in shopware

> Attackers can exploit improper access control to use admin API permissions within normal user sessions, potentially escalating privileges or accessing sensitive data.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Apr 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-9wrv-g75h-8ccc

## What is CVE-2022-24872?

CVE-2022-24872 is a high-severity missing authorization vulnerability in Shopware Shopware, published on 20 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Shopware is an open commerce platform based on Symfony Framework and Vue. Permissions set to sales channel context by admin-api are still usable within normal user session. Users are advised to update to the current version 6.4.10.1. For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. There are no known workarounds for this issue.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2022-24872?

4 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/core` | Packagist | All versions | 6.4.10.1 |
| `shopware/core` | Packagist | All versions | 6.4.10.1 |
| `shopware/platform` | Packagist | All versions | 6.4.10.1 |
| `shopware/platform` | Packagist | All versions | 6.4.10.1 |

Products: Shopware Shopware.

## How do I fix CVE-2022-24872?

Upgrade shopware/core to 6.4.10.1 or later.

## Is CVE-2022-24872 being exploited?

There is no known exploitation of CVE-2022-24872 in the wild and no public exploit code.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24872 and fix it if it is affected.

What it is: CVE-2022-24872 is a high-severity missing authorization vulnerability in Shopware Shopware, published on 20 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24872 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/core (Packagist): affected all versions; fixed in 6.4.10.1
- shopware/core (Packagist): affected all versions; fixed in 6.4.10.1
- shopware/platform (Packagist): affected all versions; fixed in 6.4.10.1
- shopware/platform (Packagist): affected all versions; fixed in 6.4.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24872/ (Markdown: https://insights.sbomify.com/CVE-2022-24872/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24872
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24872
- OSV: https://osv.dev/vulnerability/CVE-2022-24872

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24872/
Summaries are generated and may contain mistakes; the official description above is the record.
