# CVE-2022-24873: Non-Stored Cross-site Scripting in Shopware storefront

> Attackers can execute arbitrary scripts in the Shopware storefront, potentially compromising user sessions and data.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Apr 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-4g29-fccr-p59w

## What is CVE-2022-24873?

CVE-2022-24873 is a medium-severity cross-site scripting vulnerability in Shopware Shopware, published on 28 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Shopware is an open source e-commerce software platform. Prior to version 5.7.9, Shopware is vulnerable to non-stored cross-site scripting in the storefront. This issue is fixed in version 5.7.9. Users of older versions may attempt to mitigate the vulnerability by using the Shopware security plugin.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-24873?

2 open source packages ship an affected version, including shopware/shopware. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/shopware` | Packagist | All versions | 5.7.9 |
| `shopware/shopware` | Packagist | All versions | 5.7.9 |

Products: Shopware Shopware.

## How do I fix CVE-2022-24873?

Upgrade shopware/shopware to 5.7.9 or later.

## Is CVE-2022-24873 being exploited?

There is no known exploitation of CVE-2022-24873 in the wild and no public exploit code.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24873 and fix it if it is affected.

What it is: CVE-2022-24873 is a medium-severity cross-site scripting vulnerability in Shopware Shopware, published on 28 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-24873 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/shopware (Packagist): affected all versions; fixed in 5.7.9
- shopware/shopware (Packagist): affected all versions; fixed in 5.7.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24873/ (Markdown: https://insights.sbomify.com/CVE-2022-24873/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24873
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24873
- OSV: https://osv.dev/vulnerability/CVE-2022-24873

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24873/
Summaries are generated and may contain mistakes; the official description above is the record.
