# CVE-2022-24878: Improper path handling in Kustomization files allows for denial of service

> An attacker can cause a denial of service in the kustomize-controller by submitting a malicious kustomization.yaml file with improper path handling.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 May 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-flux-2022-24878, BIT-kustomize-2022-24878, GHSA-7pwf-jg34-hxwp, GO-2022-0448

## What is CVE-2022-24878?

CVE-2022-24878 is a high-severity path traversal vulnerability in fluxcd flux2, published on 6 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flux is an open and extensible continuous delivery solution for Kubernetes. Path Traversal in the kustomize-controller via a malicious `kustomization.yaml` allows an attacker to cause a Denial of Service at the controller level. Workarounds include automated tooling in the user's CI/CD pipeline to validate `kustomization.yaml` files conform with specific policies. This vulnerability is fixed in kustomize-controller v0.24.0 and included in flux2 v0.29.0. Users are recommended to upgrade.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-24878?

8 open source packages ship an affected version, including github.com/fluxcd/flux2, flux and kustomize. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/fluxcd/flux2` | Go | From 0.19.0 | 0.29.0 |
| `github.com/fluxcd/flux2` | Go | From 0.19.0 | 0.29.0 |
| `github.com/fluxcd/flux2` | Go | From 0.19.0 | 0.29.0 |
| `flux` | Bitnami | All versions | 0.29.0 |
| `kustomize` | Bitnami | All versions | 0.24.0 |
| `github.com/fluxcd/kustomize-controller` | Go | From 0.16.0 | 0.24.0 |
| `github.com/fluxcd/kustomize-controller` | Go | From 0.16.0 | 0.24.0 |
| `github.com/fluxcd/kustomize-controller` | Go | From 0.16.0 | 0.24.0 |

Products: Fluxcd Flux2, Fluxcd Kustomize-Controller.

## How do I fix CVE-2022-24878?

Upgrade github.com/fluxcd/flux2 to 0.29.0 or later.

## Is CVE-2022-24878 being exploited?

There is no known exploitation of CVE-2022-24878 in the wild and no public exploit code.

## Other vulnerabilities in fluxcd flux2

- [CVE-2022-24817](https://insights.sbomify.com/CVE-2022-24817/): Improper kubeconfig validation allows arbitrary code execution (critical 9.9)
- [CVE-2022-24877](https://insights.sbomify.com/CVE-2022-24877/): Improper path handling in kustomization files allows path traversal (critical 9.9)
- [CVE-2022-36049](https://insights.sbomify.com/CVE-2022-36049/): Flux2 Helm Controller denial of service (high 7.7)
- [CVE-2022-36035](https://insights.sbomify.com/CVE-2022-36035/): Flux CLI Workload Injection (high 7.7)
- [CVE-2022-39272](https://insights.sbomify.com/CVE-2022-39272/): Flux2 vulnerable to Denial of Service due to Improper use of metav1.Duration (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24878 and fix it if it is affected.

What it is: CVE-2022-24878 is a high-severity path traversal vulnerability in fluxcd flux2, published on 6 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24878 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/fluxcd/flux2 (Go): affected from 0.19.0; fixed in 0.29.0
- github.com/fluxcd/flux2 (Go): affected from 0.19.0; fixed in 0.29.0
- github.com/fluxcd/flux2 (Go): affected from 0.19.0; fixed in 0.29.0
- flux (Bitnami): affected all versions; fixed in 0.29.0
- kustomize (Bitnami): affected all versions; fixed in 0.24.0
- github.com/fluxcd/kustomize-controller (Go): affected from 0.16.0; fixed in 0.24.0
- github.com/fluxcd/kustomize-controller (Go): affected from 0.16.0; fixed in 0.24.0
- github.com/fluxcd/kustomize-controller (Go): affected from 0.16.0; fixed in 0.24.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24878/ (Markdown: https://insights.sbomify.com/CVE-2022-24878/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24878
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24878
- OSV: https://osv.dev/vulnerability/CVE-2022-24878

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24878/
Summaries are generated and may contain mistakes; the official description above is the record.
