CVE-2022-24879 Malfunction of Cross-Site Request Forgery token validation

High 7.5 Published Updated

Attackers can bypass CSRF protection in Shopware due to token validation flaws, potentially performing unauthorized actions on behalf of users.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-24879?

CVE-2022-24879 is a high-severity vulnerability in Shopware Shopware, published on 28 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Shopware is an open source e-commerce software platform. Versions prior to 5.7.9 are vulnerable to malfunction of cross-site request forgery (CSRF) token validation. Under certain circumstances, the CSRF tokens were not generated anew and not validated correctly. This issue is fixed in version 5.7.9. Users of older versions may attempt to mitigate the vulnerability by using the Shopware security plugin.

Weakness: CWE-352

Which versions are affected by CVE-2022-24879?

2 open source packages ship an affected version, including shopware/shopware. It affects 1 product.

PackageAffectedFixed in
shopware/shopware PackagistFrom 5.2.05.7.9
shopware/shopware PackagistFrom 5.2.05.7.9

Products include Shopware Shopware.

How do I fix CVE-2022-24879?

Upgrade shopware/shopware to 5.7.9 or later.

Is CVE-2022-24879 being exploited?

There is no known exploitation of CVE-2022-24879 in the wild and no public exploit code.

All Shopware Shopware vulnerabilities

Sources

Also known as GHSA-pf38-v6qj-j23h.

Is CVE-2022-24879 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free