{"answers":{"affected":"2 open source packages ship an affected version, including com.hccake:ballcat-codegen. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24881 exists.","fix":"Upgrade com.hccake:ballcat-codegen to 1.0.0.beta.2 or later.","what":"CVE-2022-24881 is a high-severity code injection vulnerability in ballcat-projects ballcat-codegen, published on 26 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24881 and fix it if it is affected.\n\nWhat it is: CVE-2022-24881 is a high-severity code injection vulnerability in ballcat-projects ballcat-codegen, published on 26 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24881 exists.\n\nAffected packages and fixed versions:\n- com.hccake:ballcat-codegen (Maven): affected all versions; fixed in 1.0.0.beta.2\n- com.hccake:ballcat-codegen (Maven): affected all versions; fixed in 1.0.0.beta.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24881/ (Markdown: https://insights.sbomify.com/CVE-2022-24881/index.md)","id":"CVE-2022-24881","markdown":"https://insights.sbomify.com/CVE-2022-24881/index.md","name":"CVE-2022-24881","record":{"aliases":["GHSA-fv3m-xhqw-9m79"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Java code generation library","requires_auth":"low_privilege","summary":"Attackers can achieve remote code execution by injecting malicious code into templates due to insufficient input validation in the Ballcat Codegen library.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"codegen","vendor":"ballcat"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"},{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Ballcat Codegen provides the function of online editing code to generate templates. In versions prior to 1.0.0.beta.2, attackers can implement remote code execution through malicious code injection of the template engine. This happens because Velocity and freemarker templates are introduced but input verification is not done. The fault is rectified in version 1.0.0.beta.2.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Command Injection in Ballcat Codegen","id":"CVE-2022-24881","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Server side NTLM does not properly check parameters in FreeRDP","id":"CVE-2022-24882"},"packages":[{"ecosystem":"Maven","fixed":["1.0.0.beta.2"],"introduced":["0"],"last_affected":[],"package":"com.hccake:ballcat-codegen","purl":null,"source":"GHSA-fv3m-xhqw-9m79"},{"ecosystem":"Maven","fixed":["1.0.0.beta.2"],"introduced":["0"],"last_affected":[],"package":"com.hccake:ballcat-codegen","purl":"pkg:maven/com.hccake/ballcat-codegen","source":"GHSA-fv3m-xhqw-9m79"}],"prev":{"headline":"Potential Captcha Validate Bypass in flask-session-captcha","id":"CVE-2022-24880"},"products":["ballcat-codegen"],"published":"2022-04-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["ballcat-projects"]},"summary":"Attackers can achieve remote code execution by injecting malicious code into templates due to insufficient input validation in the Ballcat Codegen library.","url":"https://insights.sbomify.com/CVE-2022-24881/"}