CVE-2022-24889 Insufficient Verification of Data Authenticity in Nextcloud Server

Low 2.4 Published Updated

Attackers can trick administrators into enabling unnecessary recommended apps, expanding the attack surface of the Nextcloud server.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2022-24889?

CVE-2022-24889 is a low-severity vulnerability in Nextcloud Nextcloud Server, published on 27 Apr 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Nextcloud Server is the file server software for Nextcloud, a self-hosted productivity platform. Prior to versions 21.0.8, 22.2.4, and 23.0.1, it is possible to trick administrators into enabling "recommended" apps for the Nextcloud server that they do not need, thus expanding their attack surface unnecessarily. This issue is fixed in versions 21.0.8 , 22.2.4, and 23.0.1.

Weakness: CWE-345

Which versions are affected by CVE-2022-24889?

It affects 1 product.

Products include Nextcloud Nextcloud Server.

How do I fix CVE-2022-24889?

No fix has been published for CVE-2022-24889 yet. Limit exposure of the affected software until one is available.

Is CVE-2022-24889 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24889 exists.

All Nextcloud Nextcloud Server vulnerabilities

Sources

Also known as GHSA-5vw6-6prg-gvw6.

Is CVE-2022-24889 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free