# CVE-2022-24891: Cross-site Scripting in org.owasp.esapi:esapi -- antisamy-esapi.xml configuration file

> Attackers can execute arbitrary scripts via unsanitized javascript URLs due to a flawed regex in the ESAPI library configuration.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Apr 2022
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2022-24891, GHSA-q77q-vx4q-xx6q, UBUNTU-CVE-2022-24891

## What is CVE-2022-24891?

CVE-2022-24891 is a medium-severity cross-site scripting vulnerability in Netapp Active Iq Unified Manager, published on 27 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

ESAPI (The OWASP Enterprise Security API) is a free, open source, web application security control library. Prior to version 2.3.0.0, there is a potential for a cross-site scripting vulnerability in ESAPI caused by a incorrect regular expression for "onsiteURL" in the **antisamy-esapi.xml** configuration file that can cause "javascript:" URLs to fail to be correctly sanitized. This issue is patched in ESAPI 2.3.0.0. As a workaround, manually edit the **antisamy-esapi.xml** configuration files to change the "onsiteURL" regular expression. More information about remediation of the vulnerability, including the workaround, is available in the maintainers' release notes and security bulletin.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-24891?

2 open source packages ship an affected version, including org.owasp.esapi:esapi. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.owasp.esapi:esapi` | Maven | All versions | 2.3.0.0 |
| `org.owasp.esapi:esapi` | Maven | All versions | 2.3.0.0 |

Products: Netapp Active Iq Unified Manager, Netapp Oncommand Workflow Automation, Oracle Weblogic Server, Owasp Enterprise Security Api.

## How do I fix CVE-2022-24891?

Upgrade org.owasp.esapi:esapi to 2.3.0.0 or later.

## Is CVE-2022-24891 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24891 exists.

Public exploit code:

- https://github.com/shoucheng3/ESAPI__esapi-java-legacy_CVE-2022-24891_2-2-3-1 (github_poc): https://github.com/shoucheng3/ESAPI__esapi-java-legacy_CVE-2022-24891_2-2-3-1

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2022-31692](https://insights.sbomify.com/CVE-2022-31692/): Spring Security authorization rules can be bypassed via forward or include dispatcher types (critical 9.8)
- [CVE-2022-2526](https://insights.sbomify.com/CVE-2022-2526/): Use after free in systemd-resolved (critical 9.8)
- [CVE-2022-22978](https://insights.sbomify.com/CVE-2022-22978/): Authorization bypass in Spring Security (critical 9.8)
- [CVE-2021-22931](https://insights.sbomify.com/CVE-2021-22931/): Code injection in Node (critical 9.8)
- [CVE-2018-2938](https://insights.sbomify.com/CVE-2018-2938/): Code injection in Java (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24891 and fix it if it is affected.

What it is: CVE-2022-24891 is a medium-severity cross-site scripting vulnerability in Netapp Active Iq Unified Manager, published on 27 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24891 exists.

Affected packages and fixed versions:
- org.owasp.esapi:esapi (Maven): affected all versions; fixed in 2.3.0.0
- org.owasp.esapi:esapi (Maven): affected all versions; fixed in 2.3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24891/ (Markdown: https://insights.sbomify.com/CVE-2022-24891/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24891
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24891
- OSV: https://osv.dev/vulnerability/CVE-2022-24891

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24891/
Summaries are generated and may contain mistakes; the official description above is the record.
