# CVE-2022-24897: Arbitrary filesystem write access from Velocity

> Attackers with Script rights can bypass Velocity sandboxing to read or write arbitrary files on the server filesystem.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 May 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-cvx5-m8vg-vxgc

## What is CVE-2022-24897?

CVE-2022-24897 is a high-severity path traversal vulnerability in Xwiki Xwiki, published on 2 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

APIs to evaluate content with Velocity is a package for APIs to evaluate content with Velocity. Starting with version 2.3 and prior to 12.6.7, 12.10.3, and 13.0, the velocity scripts are not properly sandboxed against using the Java File API to perform read or write operations on the filesystem. Writing an attacking script in Velocity requires the Script rights in XWiki so not all users can use it, and it also requires finding an XWiki API which returns a File. The problem has been patched in versions 12.6.7, 12.10.3, and 13.0. There is no easy workaround for fixing this vulnerability other than upgrading and being careful when giving Script rights.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-24897?

4 open source packages ship an affected version, including org.xwiki.commons:xwiki-commons-velocity. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.commons:xwiki-commons-velocity` | Maven | From 12.7.0 | 12.10.3 |
| `org.xwiki.commons:xwiki-commons-velocity` | Maven | From 12.7.0 | 12.10.3 |
| `org.xwiki.commons:xwiki-commons-velocity` | Maven | From 2.3.0 | 12.6.7 |
| `org.xwiki.commons:xwiki-commons-velocity` | Maven | From 2.3.0 | 12.6.7 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-24897?

Upgrade org.xwiki.commons:xwiki-commons-velocity to a fixed version for your release line: 12.10.3 or 12.6.7.

## Is CVE-2022-24897 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24897 exists.

Public exploit code:

- https://github.com/shoucheng3/xwiki__xwiki-commons_CVE-2022-24897_12-6-6 (github_poc): https://github.com/shoucheng3/xwiki__xwiki-commons_CVE-2022-24897_12-6-6

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24897 and fix it if it is affected.

What it is: CVE-2022-24897 is a high-severity path traversal vulnerability in Xwiki Xwiki, published on 2 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24897 exists.

Affected packages and fixed versions:
- org.xwiki.commons:xwiki-commons-velocity (Maven): affected from 12.7.0; fixed in 12.10.3
- org.xwiki.commons:xwiki-commons-velocity (Maven): affected from 12.7.0; fixed in 12.10.3
- org.xwiki.commons:xwiki-commons-velocity (Maven): affected from 2.3.0; fixed in 12.6.7
- org.xwiki.commons:xwiki-commons-velocity (Maven): affected from 2.3.0; fixed in 12.6.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24897/ (Markdown: https://insights.sbomify.com/CVE-2022-24897/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24897
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24897
- OSV: https://osv.dev/vulnerability/CVE-2022-24897

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24897/
Summaries are generated and may contain mistakes; the official description above is the record.
