# CVE-2022-24899: Cross site scripting via canonical tag

> Attackers can inject malicious scripts into the canonical tag of Contao CMS websites, potentially executing code in victim browsers.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-m8x6-6r63-qvj2

## What is CVE-2022-24899?

CVE-2022-24899 is a high-severity cross-site scripting vulnerability in contao, published on 5 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Contao is a powerful open source CMS that allows you to create professional websites and scalable web applications. In versions of Contao prior to 4.13.3 it is possible to inject code into the canonical tag. As a workaround users may disable canonical tags in the root page settings.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-24899?

4 open source packages ship an affected version, including contao/contao and contao/core-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `contao/contao` | Packagist | From 4.13.0 | 4.13.3 |
| `contao/contao` | Packagist | From 4.13.0 | 4.13.3 |
| `contao/core-bundle` | Packagist | From 4.13.0 | 4.13.3 |
| `contao/core-bundle` | Packagist | From 4.13.0 | 4.13.3 |

Products: Contao Contao.

## How do I fix CVE-2022-24899?

Upgrade contao/contao to 4.13.3 or later.

## Is CVE-2022-24899 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24899 exists.

Public exploit code:

- Contao <4.13.3 - Cross-Site Scripting (nuclei): http/cves/2022/CVE-2022-24899.yaml

## Other vulnerabilities in contao

- [CVE-2022-26265](https://insights.sbomify.com/CVE-2022-26265/): Remote Code Execution in Contao Managed Edition (critical 9.8)
- [CVE-2019-11512](https://insights.sbomify.com/CVE-2019-11512/): Contao SQL injection in the file manager (critical 9.8)
- [CVE-2012-4383](https://insights.sbomify.com/CVE-2012-4383/): Contao core SQL Injection Vulnerability (high 8.8)
- [CVE-2019-19745](https://insights.sbomify.com/CVE-2019-19745/): Unrestricted file uploads in Contao (high 8.8)
- [CVE-2024-28235](https://insights.sbomify.com/CVE-2024-28235/): Contao possible cookie sharing with external domains while checking protected pages for broken links (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24899 and fix it if it is affected.

What it is: CVE-2022-24899 is a high-severity cross-site scripting vulnerability in contao, published on 5 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-24899 exists.

Affected packages and fixed versions:
- contao/contao (Packagist): affected from 4.13.0; fixed in 4.13.3
- contao/contao (Packagist): affected from 4.13.0; fixed in 4.13.3
- contao/core-bundle (Packagist): affected from 4.13.0; fixed in 4.13.3
- contao/core-bundle (Packagist): affected from 4.13.0; fixed in 4.13.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24899/ (Markdown: https://insights.sbomify.com/CVE-2022-24899/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24899
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24899
- OSV: https://osv.dev/vulnerability/CVE-2022-24899

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24899/
Summaries are generated and may contain mistakes; the official description above is the record.
