# CVE-2022-24905: Argo CD login screen allows message spoofing if SSO is enabled

> Attackers can spoof login screen messages in Argo CD when SSO is enabled, potentially misleading users, though active content injection is prevented.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 May 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-xmg8-99r8-jc2j, GO-2022-0454

## What is CVE-2022-24905?

CVE-2022-24905 is a medium-severity cross-site scripting vulnerability in Argoproj Argo Cd, published on 20 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Argo CD is a declarative, GitOps continuous delivery tool for Kubernetes. A vulnerability was found in Argo CD prior to versions 2.3.4, 2.2.9, and 2.1.15 that allows an attacker to spoof error messages on the login screen when single sign on (SSO) is enabled. In order to exploit this vulnerability, an attacker would have to trick the victim to visit a specially crafted URL which contains the message to be displayed. As far as the research of the Argo CD team concluded, it is not possible to specify any active content (e.g. Javascript) or other HTML fragments (e.g. clickable links) in the spoofed message. A patch for this vulnerability has been released in Argo CD versions 2.3.4, 2.2.9, and 2.1.15. There are currently no known workarounds.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-24905?

10 open source packages ship an affected version, including github.com/argoproj/argo-cd/v2 and github.com/argoproj/argo-cd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/argoproj/argo-cd/v2` | Go | From 2.0.0 | 2.1.15, 2.2.9, 2.3.4 |
| `github.com/argoproj/argo-cd/v2` | Go | From 2.0.0 | 2.1.15 |
| `github.com/argoproj/argo-cd/v2` | Go | From 2.0.0 | 2.1.15 |
| `github.com/argoproj/argo-cd/v2` | Go | From 2.2.0 | 2.2.9 |
| `github.com/argoproj/argo-cd/v2` | Go | From 2.2.0 | 2.2.9 |
| `github.com/argoproj/argo-cd/v2` | Go | From 2.3.0 | 2.3.4 |
| `github.com/argoproj/argo-cd/v2` | Go | From 2.3.0 | 2.3.4 |
| `github.com/argoproj/argo-cd` | Go | All versions | None |
| `github.com/argoproj/argo-cd` | Go | All versions | 2.1.15 |
| `github.com/argoproj/argo-cd` | Go | All versions | 2.1.15 |

Products: Argoproj Argo Cd.

## How do I fix CVE-2022-24905?

Upgrade github.com/argoproj/argo-cd/v2 to a fixed version for your release line: 2.1.15, 2.2.9 or 2.3.4.

## Is CVE-2022-24905 being exploited?

There is no known exploitation of CVE-2022-24905 in the wild and no public exploit code.

## Other vulnerabilities in Argoproj Argo Cd

- [CVE-2025-55190](https://insights.sbomify.com/CVE-2025-55190/): Argo CD: Project API Token Exposes Repository Credentials (critical 10.0)
- [CVE-2022-29165](https://insights.sbomify.com/CVE-2022-29165/): Argo CD will blindly trust JWT claims if anonymous access is enabled (critical 10.0)
- [CVE-2023-40029](https://insights.sbomify.com/CVE-2023-40029/): Cluster secret might leak in cluster details page in Argo CD (critical 9.9)
- [CVE-2022-24768](https://insights.sbomify.com/CVE-2022-24768/): Improper access control allows admin privilege escalation in Argo CD (critical 9.9)
- [CVE-2024-21652](https://insights.sbomify.com/CVE-2024-21652/): Argo CD vulnerable to Bypassing of Brute Force Protection via Application Crash and In-Memory Data Loss (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24905 and fix it if it is affected.

What it is: CVE-2022-24905 is a medium-severity cross-site scripting vulnerability in Argoproj Argo Cd, published on 20 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-24905 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/argoproj/argo-cd/v2 (Go): affected from 2.0.0; fixed in 2.1.15, 2.2.9, 2.3.4
- github.com/argoproj/argo-cd/v2 (Go): affected from 2.0.0; fixed in 2.1.15
- github.com/argoproj/argo-cd/v2 (Go): affected from 2.0.0; fixed in 2.1.15
- github.com/argoproj/argo-cd/v2 (Go): affected from 2.2.0; fixed in 2.2.9
- github.com/argoproj/argo-cd/v2 (Go): affected from 2.2.0; fixed in 2.2.9
- github.com/argoproj/argo-cd/v2 (Go): affected from 2.3.0; fixed in 2.3.4
- github.com/argoproj/argo-cd/v2 (Go): affected from 2.3.0; fixed in 2.3.4
- github.com/argoproj/argo-cd (Go): affected all versions; no fix listed
- github.com/argoproj/argo-cd (Go): affected all versions; fixed in 2.1.15
- github.com/argoproj/argo-cd (Go): affected all versions; fixed in 2.1.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24905/ (Markdown: https://insights.sbomify.com/CVE-2022-24905/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24905
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24905
- OSV: https://osv.dev/vulnerability/CVE-2022-24905

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24905/
Summaries are generated and may contain mistakes; the official description above is the record.
