CVE-2022-24921 Denial of service in n/a
Attackers can cause stack exhaustion and denial of service by providing deeply nested regular expressions to the Go regexp.Compile function.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-24921?
CVE-2022-24921 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 5 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
regexp.Compile in Go before 1.16.15 and 1.17.x before 1.17.8 allows stack exhaustion via a deeply nested expression.
Weakness: CWE-674
Which versions are affected by CVE-2022-24921?
2 open source packages ship an affected version, including golang and stdlib. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
golang Bitnami | All versions | 1.16.15, 1.17.8 |
stdlib Go | All versions | 1.16.15, 1.17.8 |
Linux distribution packages (26)
go1.16 SUSE:Enterprise Storage 7 | All versions | 1.16.15-150000.1.46.1 |
go1.17 SUSE:Enterprise Storage 7 | All versions | 1.17.8-150000.1.25.1 |
go1.16 SUSE:Linux Enterprise High Performance Computing 15 SP2-ESPOS | All versions | 1.16.15-150000.1.46.1 |
go1.17 SUSE:Linux Enterprise High Performance Computing 15 SP2-ESPOS | All versions | 1.17.8-150000.1.25.1 |
go1.16 SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 1.16.15-150000.1.46.1 |
go1.17 SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 1.17.8-150000.1.25.1 |
go1.16 SUSE:Linux Enterprise Module for Development Tools 15 SP3 | All versions | 1.16.15-150000.1.46.1 |
go1.17 SUSE:Linux Enterprise Module for Development Tools 15 SP3 | All versions | 1.17.8-150000.1.25.1 |
go1.16 SUSE:Linux Enterprise Real Time 15 SP2 | All versions | 1.16.15-150000.1.46.1 |
go1.17 SUSE:Linux Enterprise Real Time 15 SP2 | All versions | 1.17.8-150000.1.25.1 |
go1.16 SUSE:Linux Enterprise Server 15 SP2-BCL | All versions | 1.16.15-150000.1.46.1 |
go1.17 SUSE:Linux Enterprise Server 15 SP2-BCL | All versions | 1.17.8-150000.1.25.1 |
go1.16 SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 1.16.15-150000.1.46.1 |
go1.17 SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 1.17.8-150000.1.25.1 |
go1.16 SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 1.16.15-150000.1.46.1 |
go1.17 SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 1.17.8-150000.1.25.1 |
go1.16 SUSE:Manager Proxy 4.1 | All versions | 1.16.15-150000.1.46.1 |
go1.17 SUSE:Manager Proxy 4.1 | All versions | 1.17.8-150000.1.25.1 |
go1.16 SUSE:Manager Retail Branch Server 4.1 | All versions | 1.16.15-150000.1.46.1 |
go1.17 SUSE:Manager Retail Branch Server 4.1 | All versions | 1.17.8-150000.1.25.1 |
go1.16 SUSE:Manager Server 4.1 | All versions | 1.16.15-150000.1.46.1 |
go1.17 SUSE:Manager Server 4.1 | All versions | 1.17.8-150000.1.25.1 |
go1.16 openSUSE:Leap 15.3 | All versions | 1.16.15-150000.1.46.1 |
go1.17 openSUSE:Leap 15.3 | All versions | 1.17.8-150000.1.25.1 |
go1.16 openSUSE:Tumbleweed | All versions | 1.16.15-1.1 |
go1.17 openSUSE:Tumbleweed | All versions | 1.17.8-1.1 |
Products include Debian Debian Linux, Golang Go, Netapp Astra Trident.
How do I fix CVE-2022-24921?
Upgrade golang to a fixed version for your release line: 1.16.15 or 1.17.8.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-24921 being exploited?
There is no known exploitation of CVE-2022-24921 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as AZL-79112, AZL-8898, AZL-98922, BIT-golang-2022-24921, DEBIAN-CVE-2022-24921, GHSA-6685-ffxp-xm6f and 8 more.