# CVE-2022-24921: Denial of service in n/a

> Attackers can cause stack exhaustion and denial of service by providing deeply nested regular expressions to the Go regexp.Compile function.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** AZL-79112, AZL-8898, AZL-98922, BIT-golang-2022-24921, DEBIAN-CVE-2022-24921, GHSA-6685-ffxp-xm6f, GO-2021-0347, MGASA-2022-0126, OESA-2022-1590, SUSE-SU-2022:1164-1, SUSE-SU-2022:1167-1, UBUNTU-CVE-2022-24921, openSUSE-SU-2024:11892-1, openSUSE-SU-2024:11893-1

## What is CVE-2022-24921?

CVE-2022-24921 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 5 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

regexp.Compile in Go before 1.16.15 and 1.17.x before 1.17.8 allows stack exhaustion via a deeply nested expression.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2022-24921?

2 open source packages ship an affected version, including golang and stdlib. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `golang` | Bitnami | All versions | 1.16.15, 1.17.8 |
| `stdlib` | Go | All versions | 1.16.15, 1.17.8 |
| `go1.16` | SUSE:Enterprise Storage 7 | All versions | 1.16.15-150000.1.46.1 |
| `go1.17` | SUSE:Enterprise Storage 7 | All versions | 1.17.8-150000.1.25.1 |
| `go1.16` | SUSE:Linux Enterprise High Performance Computing 15 SP2-ESPOS | All versions | 1.16.15-150000.1.46.1 |
| `go1.17` | SUSE:Linux Enterprise High Performance Computing 15 SP2-ESPOS | All versions | 1.17.8-150000.1.25.1 |
| `go1.16` | SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 1.16.15-150000.1.46.1 |
| `go1.17` | SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 1.17.8-150000.1.25.1 |
| `go1.16` | SUSE:Linux Enterprise Module for Development Tools 15 SP3 | All versions | 1.16.15-150000.1.46.1 |
| `go1.17` | SUSE:Linux Enterprise Module for Development Tools 15 SP3 | All versions | 1.17.8-150000.1.25.1 |
| `go1.16` | SUSE:Linux Enterprise Real Time 15 SP2 | All versions | 1.16.15-150000.1.46.1 |
| `go1.17` | SUSE:Linux Enterprise Real Time 15 SP2 | All versions | 1.17.8-150000.1.25.1 |
| `go1.16` | SUSE:Linux Enterprise Server 15 SP2-BCL | All versions | 1.16.15-150000.1.46.1 |
| `go1.17` | SUSE:Linux Enterprise Server 15 SP2-BCL | All versions | 1.17.8-150000.1.25.1 |
| `go1.16` | SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 1.16.15-150000.1.46.1 |
| `go1.17` | SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 1.17.8-150000.1.25.1 |
| `go1.16` | SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 1.16.15-150000.1.46.1 |
| `go1.17` | SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 1.17.8-150000.1.25.1 |
| `go1.16` | SUSE:Manager Proxy 4.1 | All versions | 1.16.15-150000.1.46.1 |
| `go1.17` | SUSE:Manager Proxy 4.1 | All versions | 1.17.8-150000.1.25.1 |
| `go1.16` | SUSE:Manager Retail Branch Server 4.1 | All versions | 1.16.15-150000.1.46.1 |
| `go1.17` | SUSE:Manager Retail Branch Server 4.1 | All versions | 1.17.8-150000.1.25.1 |
| `go1.16` | SUSE:Manager Server 4.1 | All versions | 1.16.15-150000.1.46.1 |
| `go1.17` | SUSE:Manager Server 4.1 | All versions | 1.17.8-150000.1.25.1 |
| `go1.16` | openSUSE:Leap 15.3 | All versions | 1.16.15-150000.1.46.1 |
| `go1.17` | openSUSE:Leap 15.3 | All versions | 1.17.8-150000.1.25.1 |
| `go1.16` | openSUSE:Tumbleweed | All versions | 1.16.15-1.1 |
| `go1.17` | openSUSE:Tumbleweed | All versions | 1.17.8-1.1 |

Products: Debian Debian Linux, Golang Go, Netapp Astra Trident.

## How do I fix CVE-2022-24921?

Upgrade golang to a fixed version for your release line: 1.16.15 or 1.17.8.

## Is CVE-2022-24921 being exploited?

There is no known exploitation of CVE-2022-24921 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24921 and fix it if it is affected.

What it is: CVE-2022-24921 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 5 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24921 in the wild and no public exploit code.

Affected packages and fixed versions:
- golang (Bitnami): affected all versions; fixed in 1.16.15, 1.17.8
- stdlib (Go): affected all versions; fixed in 1.16.15, 1.17.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24921/ (Markdown: https://insights.sbomify.com/CVE-2022-24921/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24921
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24921
- OSV: https://osv.dev/vulnerability/CVE-2022-24921

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24921/
Summaries are generated and may contain mistakes; the official description above is the record.
