# CVE-2022-24947: Apache JSPWiki CSRF Account Takeover

> Attackers can perform CSRF attacks on user preferences to take over accounts in Apache JSPWiki.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-4284-x26r-4hhc

## What is CVE-2022-24947?

CVE-2022-24947 is a high-severity vulnerability in Apache JSPWiki, published on 25 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Apache JSPWiki user preferences form is vulnerable to CSRF attacks, which can lead to account takeover. Apache JSPWiki users should upgrade to 2.11.2 or later.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2022-24947?

2 open source packages ship an affected version, including org.apache.jspwiki:jspwiki-main. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.jspwiki:jspwiki-main` | Maven | All versions | 2.11.2 |
| `org.apache.jspwiki:jspwiki-main` | Maven | All versions | 2.11.2 |

Products: Apache Jspwiki.

## How do I fix CVE-2022-24947?

Upgrade org.apache.jspwiki:jspwiki-main to 2.11.2 or later.

## Is CVE-2022-24947 being exploited?

There is no known exploitation of CVE-2022-24947 in the wild and no public exploit code.

## Other vulnerabilities in Apache JSPWiki

- [CVE-2026-28812](https://insights.sbomify.com/CVE-2026-28812/): Apache JSPWiki: UserManager does not sanity-check user database at startup (critical 9.8)
- [CVE-2021-44140](https://insights.sbomify.com/CVE-2021-44140/): Arbitrary file deletion on logout (critical 9.1)
- [CVE-2026-28813](https://insights.sbomify.com/CVE-2026-28813/): Apache JSPWiki: JSPWiki vulnerable to JSON hijacking (high 8.8)
- [CVE-2022-34158](https://insights.sbomify.com/CVE-2022-34158/): User Group Privilege Escalation (high 8.8)
- [CVE-2026-28811](https://insights.sbomify.com/CVE-2026-28811/): Apache JSPWiki: Error Handling - Reveals Error Details (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24947 and fix it if it is affected.

What it is: CVE-2022-24947 is a high-severity vulnerability in Apache JSPWiki, published on 25 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-24947 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.jspwiki:jspwiki-main (Maven): affected all versions; fixed in 2.11.2
- org.apache.jspwiki:jspwiki-main (Maven): affected all versions; fixed in 2.11.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24947/ (Markdown: https://insights.sbomify.com/CVE-2022-24947/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24947
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24947
- OSV: https://osv.dev/vulnerability/CVE-2022-24947

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24947/
Summaries are generated and may contain mistakes; the official description above is the record.
