{"answers":{"affected":"2 open source packages ship an affected version, including pear/crypt_gpg. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-24953 in the wild and no public exploit code.","fix":"Upgrade pear/crypt_gpg to 1.6.7 or later.","what":"CVE-2022-24953 is a medium-severity command injection vulnerability in n/a, published on 17 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24953 and fix it if it is affected.\n\nWhat it is: CVE-2022-24953 is a medium-severity command injection vulnerability in n/a, published on 17 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-24953 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pear/crypt_gpg (Packagist): affected all versions; fixed in 1.6.7\n- pear/crypt_gpg (Packagist): affected all versions; fixed in 1.6.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24953/ (Markdown: https://insights.sbomify.com/CVE-2022-24953/index.md)","id":"CVE-2022-24953","markdown":"https://insights.sbomify.com/CVE-2022-24953/index.md","name":"CVE-2022-24953","record":{"aliases":["DEBIAN-CVE-2022-24953","GHSA-59x4-67mh-px54","UBUNTU-CVE-2022-24953"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP GPG extension","requires_auth":"none","summary":"Attackers can inject additional options into GPG calls via the Crypt_GPG PHP extension, potentially leading to arbitrary code execution.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"crypt_gpg","vendor":"pear"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"}],"description":"The Crypt_GPG extension before 1.6.7 for PHP does not prevent additional options in GPG calls, which presents a risk for certain environments and GPG versions.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Crypt_GPG does not prevent additional options in GPG calls","id":"CVE-2022-24953","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Memory corruption in n/a","id":"CVE-2022-24954"},"packages":[{"ecosystem":"Packagist","fixed":["1.6.7"],"introduced":["0"],"last_affected":[],"package":"pear/crypt_gpg","purl":null,"source":"GHSA-59x4-67mh-px54"},{"ecosystem":"Packagist","fixed":["1.6.7"],"introduced":["0"],"last_affected":[],"package":"pear/crypt_gpg","purl":"pkg:composer/pear/crypt_gpg","source":"GHSA-59x4-67mh-px54"}],"prev":{"headline":"Several denial of service vulnerabilities exist in Eternal Terminal prior to version 6.2.0, including a DoS triggered remotely by an invalid","id":"CVE-2022-24952"},"products":["n/a"],"published":"2022-02-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Attackers can inject additional options into GPG calls via the Crypt_GPG PHP extension, potentially leading to arbitrary code execution.","url":"https://insights.sbomify.com/CVE-2022-24953/"}