{"answers":{"affected":"1 open source package ship an affected version, including apr. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-24963 in the wild and no public exploit code.","fix":"Upgrade apr to 1.7.1 or later.","what":"CVE-2022-24963 is a critical vulnerability in Apache Portable Runtime (APR), published on 31 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24963 and fix it if it is affected.\n\nWhat it is: CVE-2022-24963 is a critical vulnerability in Apache Portable Runtime (APR), published on 31 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-24963 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apr (Bitnami): affected from 1.7.0; fixed in 1.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24963/ (Markdown: https://insights.sbomify.com/CVE-2022-24963/index.md)","id":"CVE-2022-24963","markdown":"https://insights.sbomify.com/CVE-2022-24963/index.md","name":"CVE-2022-24963","record":{"aliases":["ALPINE-CVE-2022-24963","ALSA-2023:7711","AZL-13226","AZL-34546","BIT-apr-2022-24963","CLSA-2025-1762338135","DEBIAN-CVE-2022-24963","DSA-5370-1","GHSA-6rr3-mpxq-hv4x","MGASA-2023-0063","OESA-2023-1095","OESA-2023-1096","OESA-2023-1117","OESA-2023-1118","RHSA-2023:7711","RLSA-2023:7711","UBUNTU-CVE-2022-24963","USN-5885-1","openSUSE-SU-2024:12655-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Portable Runtime","requires_auth":"none","summary":"An integer overflow in APR encoding functions allows attackers to write beyond buffer bounds, potentially leading to code execution or crashes.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"portable_runtime","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"Integer Overflow or Wraparound vulnerability in apr_encode functions of Apache Portable Runtime (APR) allows an attacker to write beyond bounds of a buffer.\nThis issue affects Apache Portable Runtime (APR) version 1.7.0.","ecosystems":["AlmaLinux:9","Bitnami","Red Hat:enterprise_linux:9::appstream","Rocky Linux:9","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Portable Runtime (APR): out-of-bound writes in the apr_encode family of functions","id":"CVE-2022-24963","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"integer_overflow","year":"2022"},"n_packages":9,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2022-24967"},"packages":[{"ecosystem":"Bitnami","fixed":["1.7.1"],"introduced":["1.7.0"],"last_affected":[],"package":"apr","purl":"pkg:bitnami/apr","source":"BIT-apr-2022-24963"},{"ecosystem":"AlmaLinux:9","fixed":["1.7.0-12.el9_3"],"introduced":["0"],"last_affected":[],"package":"apr","purl":"pkg:rpm/almalinux/apr","source":"ALSA-2023:7711"},{"ecosystem":"AlmaLinux:9","fixed":["1.7.0-12.el9_3"],"introduced":["0"],"last_affected":[],"package":"apr-devel","purl":"pkg:rpm/almalinux/apr-devel","source":"ALSA-2023:7711"},{"ecosystem":"Red Hat:enterprise_linux:9::appstream","fixed":["0:1.7.0-12.el9_3"],"introduced":["0"],"last_affected":[],"package":"apr","purl":"pkg:rpm/redhat/apr","source":"RHSA-2023:7711"},{"ecosystem":"Red Hat:enterprise_linux:9::appstream","fixed":["0:1.7.0-12.el9_3"],"introduced":["0"],"last_affected":[],"package":"apr-debuginfo","purl":"pkg:rpm/redhat/apr-debuginfo","source":"RHSA-2023:7711"},{"ecosystem":"Red Hat:enterprise_linux:9::appstream","fixed":["0:1.7.0-12.el9_3"],"introduced":["0"],"last_affected":[],"package":"apr-debugsource","purl":"pkg:rpm/redhat/apr-debugsource","source":"RHSA-2023:7711"},{"ecosystem":"Red Hat:enterprise_linux:9::appstream","fixed":["0:1.7.0-12.el9_3"],"introduced":["0"],"last_affected":[],"package":"apr-devel","purl":"pkg:rpm/redhat/apr-devel","source":"RHSA-2023:7711"},{"ecosystem":"Rocky Linux:9","fixed":["0:1.7.0-12.el9_3"],"introduced":["0"],"last_affected":[],"package":"apr","purl":"pkg:rpm/rocky-linux/apr?distro=rocky-linux-9\u0026epoch=0","source":"RLSA-2023:7711"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.7.2-1.1"],"introduced":["0"],"last_affected":[],"package":"apr","purl":"pkg:rpm/opensuse/apr\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12655-1"}],"prev":{"headline":"Missing authorization in n/a","id":"CVE-2022-24961"},"products":["Apache Portable Runtime (APR)"],"published":"2023-01-31","related":[{"cvss_score":9.8,"headline":"Apache Portable Runtime (APR): Windows out-of-bounds write in apr_socket_sendv function","id":"CVE-2022-28331","kev_date_added":null,"published":"2023-01-31"},{"cvss_score":7.1,"headline":"Regression of CVE-2017-12613","id":"CVE-2021-35940","kev_date_added":null,"published":"2021-08-23"},{"cvss_score":7.1,"headline":"Information disclosure in Apache Portable Runtime","id":"CVE-2017-12613","kev_date_added":null,"published":"2017-10-24"},{"cvss_score":5.5,"headline":"Apache Portable Runtime (APR): Unexpected lax shared memory permissions","id":"CVE-2023-49582","kev_date_added":null,"published":"2024-08-26"},{"cvss_score":5,"headline":"Denial of service in n/a","id":"CVE-2012-0840","kev_date_added":null,"published":"2012-02-10"}],"sources":[{"class":"attribution","licence":"MIT","name":"AlmaLinux","prefix":"ALSA"},{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"BSD","name":"Rocky Linux","prefix":"RLSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-27","vendors":["Apache Software Foundation"]},"summary":"An integer overflow in APR encoding functions allows attackers to write beyond buffer bounds, potentially leading to code execution or crashes.","url":"https://insights.sbomify.com/CVE-2022-24963/"}