# CVE-2022-24963: Apache Portable Runtime (APR): out-of-bound writes in the apr_encode family of functions

> An integer overflow in APR encoding functions allows attackers to write beyond buffer bounds, potentially leading to code execution or crashes.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jan 2023
- **Updated:** 27 Mar 2025
- **Also known as:** ALPINE-CVE-2022-24963, ALSA-2023:7711, AZL-13226, AZL-34546, BIT-apr-2022-24963, CLSA-2025-1762338135, DEBIAN-CVE-2022-24963, DSA-5370-1, GHSA-6rr3-mpxq-hv4x, MGASA-2023-0063, OESA-2023-1095, OESA-2023-1096, OESA-2023-1117, OESA-2023-1118, RHSA-2023:7711, RLSA-2023:7711, UBUNTU-CVE-2022-24963, USN-5885-1, openSUSE-SU-2024:12655-1

## What is CVE-2022-24963?

CVE-2022-24963 is a critical vulnerability in Apache Portable Runtime (APR), published on 31 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Integer Overflow or Wraparound vulnerability in apr_encode functions of Apache Portable Runtime (APR) allows an attacker to write beyond bounds of a buffer.
This issue affects Apache Portable Runtime (APR) version 1.7.0.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2022-24963?

1 open source package ship an affected version, including apr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apr` | Bitnami | From 1.7.0 | 1.7.1 |
| `apr` | AlmaLinux:9 | All versions | 1.7.0-12.el9_3 |
| `apr-devel` | AlmaLinux:9 | All versions | 1.7.0-12.el9_3 |
| `apr` | Red Hat:enterprise_linux:9::appstream | All versions | 0:1.7.0-12.el9_3 |
| `apr-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:1.7.0-12.el9_3 |
| `apr-debugsource` | Red Hat:enterprise_linux:9::appstream | All versions | 0:1.7.0-12.el9_3 |
| `apr-devel` | Red Hat:enterprise_linux:9::appstream | All versions | 0:1.7.0-12.el9_3 |
| `apr` | Rocky Linux:9 | All versions | 0:1.7.0-12.el9_3 |
| `apr` | openSUSE:Tumbleweed | All versions | 1.7.2-1.1 |

Products: Apache Portable Runtime.

## How do I fix CVE-2022-24963?

Upgrade apr to 1.7.1 or later.

## Is CVE-2022-24963 being exploited?

There is no known exploitation of CVE-2022-24963 in the wild and no public exploit code.

## Other vulnerabilities in Apache Portable Runtime (APR)

- [CVE-2022-28331](https://insights.sbomify.com/CVE-2022-28331/): Apache Portable Runtime (APR): Windows out-of-bounds write in apr_socket_sendv function (critical 9.8)
- [CVE-2021-35940](https://insights.sbomify.com/CVE-2021-35940/): Regression of CVE-2017-12613 (high 7.1)
- [CVE-2017-12613](https://insights.sbomify.com/CVE-2017-12613/): Information disclosure in Apache Portable Runtime (high 7.1)
- [CVE-2023-49582](https://insights.sbomify.com/CVE-2023-49582/): Apache Portable Runtime (APR): Unexpected lax shared memory permissions (medium 5.5)
- [CVE-2012-0840](https://insights.sbomify.com/CVE-2012-0840/): Denial of service in n/a (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24963 and fix it if it is affected.

What it is: CVE-2022-24963 is a critical vulnerability in Apache Portable Runtime (APR), published on 31 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24963 in the wild and no public exploit code.

Affected packages and fixed versions:
- apr (Bitnami): affected from 1.7.0; fixed in 1.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24963/ (Markdown: https://insights.sbomify.com/CVE-2022-24963/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24963
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24963
- OSV: https://osv.dev/vulnerability/CVE-2022-24963

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24963/
Summaries are generated and may contain mistakes; the official description above is the record.
