CVE-2022-2497 Server-side request forgery in GitLab

High 8.5 Published Updated

A malicious developer can exfiltrate integration access tokens by modifying the integration URL to send authenticated requests to an attacker-controlled server.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-2497?

CVE-2022-2497 is a high-severity server-side request forgery vulnerability in Gitlab Gitlab, published on 5 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 12.6 before 15.0.5, all versions starting from 15.1 before 15.1.4, all versions starting from 15.2 before 15.2.1. A malicious developer could exfiltrate an integration's access token by modifying the integration URL such that authenticated requests are sent to an attacker controlled server.

Which versions are affected by CVE-2022-2497?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.6.015.0.5, 15.1.4, 15.2.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-2497?

Upgrade gitlab to a fixed version for your release line: 15.0.5, 15.1.4 or 15.2.1.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2022-2497 being exploited?

There is no known exploitation of CVE-2022-2497 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-2497, GHSA-5h7x-5p3m-j723, UBUNTU-CVE-2022-2497.

Is CVE-2022-2497 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free