CVE-2022-2498 Privilege escalation in GitLab
Attackers can trigger pipelines with the tag creator's identity instead of the subscriber's, potentially escalating privileges within GitLab EE.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-2498?
CVE-2022-2498 is a medium-severity vulnerability in Gitlab Gitlab, published on 5 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
An issue in pipeline subscriptions in GitLab EE affecting all versions from 12.8 prior to 15.0.5, 15.1 prior to 15.1.4, and 15.2 prior to 15.2.1 triggered new pipelines with the person who created the tag as the pipeline creator instead of the subscription's author.
Weakness: CWE-269
Which versions are affected by CVE-2022-2498?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 12.8.0 | 15.0.5, 15.1.4, 15.2.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-2498?
Upgrade gitlab to a fixed version for your release line: 15.0.5, 15.1.4 or 15.2.1.
Is CVE-2022-2498 being exploited?
There is no known exploitation of CVE-2022-2498 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-2498, GHSA-f5vg-g8qw-8p89, UBUNTU-CVE-2022-2498.