# CVE-2022-24988: Buffer Overflow in galois_2p8

> An off-by-one buffer overflow in the galois_2p8 Rust library allows attackers to cause memory corruption, potentially leading to code execution or crashes.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-9p8q-j6q5-mjw8

## What is CVE-2022-24988?

CVE-2022-24988 is a critical memory corruption vulnerability in n/a, published on 14 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In galois_2p8 before 0.1.2, PrimitivePolynomialField::new has an off-by-one buffer overflow for a vector.

Weakness: CWE-193 (Off-by-one Error)

## Which versions are affected by CVE-2022-24988?

2 open source packages ship an affected version, including galois_2p8. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `galois_2p8` | crates.io | All versions | 0.1.2 |
| `galois_2p8` | crates.io | All versions | 0.1.2 |

Products: Galois 2p8 Project Galois 2p8.

## How do I fix CVE-2022-24988?

Upgrade galois_2p8 to 0.1.2 or later.

## Is CVE-2022-24988 being exploited?

There is no known exploitation of CVE-2022-24988 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24988 and fix it if it is affected.

What it is: CVE-2022-24988 is a critical memory corruption vulnerability in n/a, published on 14 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24988 in the wild and no public exploit code.

Affected packages and fixed versions:
- galois_2p8 (crates.io): affected all versions; fixed in 0.1.2
- galois_2p8 (crates.io): affected all versions; fixed in 0.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24988/ (Markdown: https://insights.sbomify.com/CVE-2022-24988/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24988
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24988
- OSV: https://osv.dev/vulnerability/CVE-2022-24988

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24988/
Summaries are generated and may contain mistakes; the official description above is the record.
